Entity Info Box not showing properly

ugh… you may have a corrupted .plist… i know how to reset the whole thing but unfortunately, doing that will make sketchup act like a brand new install and all other preferences will reset to default…

depending on your setup, this could be very time consuming to get everything back to your liking.


here’s how to do it if you want to go that route…

• quit sketchup
• open Terminal.app (Applications/ Utilities)
• type or copy/paste the following in terminal then press <return>

defaults delete com.sketchup.SketchUp.2015

• relaunch sketchup
you’ll now have a brand new sketchup :slight_smile: (well, all your plugins and custom materials etc will still be there… it doesn’t delete those things… just resets the preferences is all)



some other things you can do first to save&restore your current .plist.

• navigate to:
~(user)/Library/ Preferences

• locate the file: com.sketchup.SketchUp.2015.plist

• copy the file to your desktop (option key + drag&drop will duplicate it)


now, to restore this .plist:

• quit sketchup
• go to the Preferences folder again and drag com.sketchup.SketchUp.2015.plist to the trash
• move the previously copied file from the desktop back to the Preferences folder
• using terminal.app again, use:

defaults read com.sketchup.SketchUp.2015

• relaunch sketchup and the preferences will be in the same state as they were when you first copied them (with the messed up entity info panel)


there’s probably a way to reset only the entity info panel in the .plist but i don’t know how.