Entire model... missing? hidden? Just out of sight?


#1

So I’m working on a streetscape model (base data from ArcMap, to AutoCAD, to SketchUp) and this happens:

The last thing I did was erase a single line. I have no idea what’s going on, has this happened to anyone before? Thanks for your help.


#2

I would try Edit>Undo
Then,
Camera>Zoom Extents.

Shep


#3

I tried both of those, in that order. It didn’t seem to have any effect at all.


#4

I think there have been cases like this where geometry is located miles, sometimes many many miles from the origin.

You may glean something from this help page:

http://help.sketchup.com/en/article/3000165

Shep


#5

Do you have the system to make backups. You should use file search to look for file with the extension .SKB if yoy find tha and depending on how you have file association set you can open or just change name to …skp and su will open it


#6

Any added guide line? If so, Edit > Delete Guides. Their indefinite length complicates trying to zoom to the geometry.


#7

If you are modelling to map coordinates, your model might be very, very vast.

Anssi


#8

On your suggestion, I tried that. It didn’t make any difference, but I notice that after I selected “delete guidelines”, the option to delete guidelines was still available. Does that mean that guidelines still exist that can be deleted? If so, that seems to me that something’s broken…


#9

I had that thought to, but I can’t even see the Axis lines to zoom in on


#10

Is it possible for you to share your model? I’ve recently helped fix several models that mysteriously blew up and I could take a shot at yours. Based on those models, I suspect there is a bug lurking in SU that sometimes tries to divide by a quantity that is almost zero, which causes points and/or the camera to fly away to the outer reaches of the solar system.


#11

That’s really interesting! Here’s my model, hope you can make something of it. Pleasant_Street_Old_Plan.skp (2.1 MB)


#12

You might have something there. This model, on the contrary, feels like it has collapsed into a singularity. There is about nothing visible on screen. Wherever you click, you select something. Try to draw an edge - it goes from 0,0 to 0,0 with a length of 0… None of the zoom tools, especially the standard views, seem to do anything.

Anssi


#13

Here’s a repaired model file. You will find that manyl of your annotation Texts are gone; they were the cause of the problem.

Pleasant_Street_Old_Plan.skp (937.1 KB)

As in some other models I’ve fixed recently, there were Texts that had somehow gotten moved to extreme distances from the model’s geometry content, and these caused the view’s camera to also move away to the far reaches of the galaxy, from which everything is too small to see.

Also as in those other models, your geometric content is planar but the Texts were subtly off plane. I think there is a bug in SketchUp’s handling of this situation; that you like the others were a more-or-less innocent victim who happened to touch somewhere tender! I don’t know precisely what user action is the trigger though, so I can’t advise you about how to avoid the danger except not to use Text annotation in SU - do it in LayOut instead.


#14

Did you use a plugin to select the texts? Archicad has a feature that selecting a tool and clicking ctrl-a selects all entities of the type created by the tool, but SketchUp has no native way to select by entity type.

Anssi


#16

I have an unpublished suite of Ruby code that I employ to probe for model issues such as distant and very large entities.


#17

Thank you so much, I really appreciate this!


#18

So, is there any guidance for preparing a drawing in CAD that would avoid this issue (and others)?

Shep


#19

If the problem was with Text the CAD file cannot be the culprit by itself, as the SketchUp importer ignores text and other annotations. Generally you should not use map coordinates, and if you do, there should be no actual origin markers or other geometry outside your actual model area. That will ensure that when imported into SketchUp, unticking the “Preserve drawing origin” box will work as expected and bring in the drawing at the SketchUp origin. You can use the drawing origin only when it is, roughly, within your model area in AutoCad.

Anssi


#20

As @Anssi has observed, SU doesn’t import Text from CAD, the explosion occurs while working on the model in SU after a successful import. I can’t categorically rule out that some detail of the CAD file contributes, but it also seems unlikely. The common denominators I’ve seen are that the CAD file starts as 2D and the SU user is adding Text annotations that are not on the plane of the model. I haven’t been able to induce the bug myself, so I don’t know quite what sequence of operations sets it off…sorry!