Eneroth Output Issue

When I use Eneroth on these solid components it says Output is not Solid. Native Solid Tools say the same. They say they’re all solid and I even checked with Solid Inspector2. I looked for hidden geometry/components etc, but maybe I missed something. Any ideas?
Eneroth Issue.skp (11.6 MB)

You have a softened edge in the top of the three logs very near the top of the cutting box. It results in very tiny faces which are problematic. Reduce the height of the box by 0.005870" and it’ll work fine.
Screenshot - 12_15_2021 , 11_41_45 AM

1 Like

Thanks Dave! You ever make it to SW Colorado I’ll buy you dinner. :grinning_face_with_smiling_eyes:

Another question kinda related. Is there a way to keep geometry from disappearing when zoomed in close?

For what it’s worth, the warning popup about solids does not necessarily mean that it can’t work as is, or that the output is not fixable. I was able to use E solid tools and solid inspector to fix the top log without modifying anything.

Clipping when zooming in too close is is a function of how the camera works in SketchUp. It is generally best to keep the camera in perspective mode, but one can sometimes get closer to an object without clipping by temporarily switching to parallel projection mode under Camera. You may have to hit zoom extents first then zoom in on the object in question. Just remember to switch back after working small, it’s counter intuitive but parallel projection is actually more susceptible to clipping although it can allow a closer view.


1 Like

I’ll get in my car now. :smiley: Just kidding. Thank you, though.

As for your disappearing geometry, that’s called clipping. You could reduce the clipping issue to some extent by turning off tags for things you don’t need to see. With a model the size of your cabin, zooming in really close to see that tiny geometry thing will still result in clipping.

Also turn on Hidden Geometry and do a Zoom Extents. You’ll find there are a few very tiny edges at a huge distance from the model. Up toward the top. That can increase the incidence of clipping.

Turn on Hidden Geometry and do a Zoom Extents to look for unneeded geometry and delete it. When you get done Zoom Extents should zoom into just your model.

1 Like

Thanks guys! I have a lot to learn, especially when it comes to troubleshooting, so your help is, well, helpful. :sweat_smile:

It’ll come with time. Do a lot more modeling. :smiley:

1 Like

Yep. This is by far my largest model, and I’m learning so much. Mainly because I decided I needed to know the correct way to do it. There are so many tricks that eliminate mistakes and wasted time. I would say Components, Tags, and Solid Components have been the biggest ones, alongside Eneroth and Solid Inspector. I’m definitely excited for down the road.