Empty gray areas while drawing (see photo)

My question is this, when I start Sketchup 2021 the image is 100% sharp and fine. However, when drawing, empty gray areas are created. Difficult to describe in English (I’m Dutch). I’ve added a photo showing this. I can then only get the picture perfect again by completely shutting down the PC and restarting it. However, the problem just keeps recurring. Several times Sketchup uninstalled and reinstalled. all latest drivers installed. I also had the problem with Sketchup version 2019/2020. Is this due to the settings (tried several examples from the internet), is it due to the memory, or is this video card too light and it is better to buy another one.
Thanks for response in advance.


PC - HP Pavilion Gaming 690-0970nd.
NVIDIA GeForce GTX 1060
SSD + HDD
16GB RAM


2X HP ENVY 27s Screens.
4K ultra.


SU Podium V2.x Version: 2.6.047


Sketchup PRO 2021

Post a model file that shows you this. However, my guess is that your model is placed very far from the SketchUp model origin point, or then parts of it (a single stray edge is enough) are very far. You should keep the model at or near the origin, and use the geolocation feature to put it in place in the “real world”.

1 Like

Anssi good evening (Dutch time),

1028 / 5000

Thank you for your quick response, I may not have described things well. I have included that photo because it clearly shows what I mean by “empty” areas. The same also occurs with smaller designs. I have attached another photo as an example. As an extra explanation, I start Sketchup empty in a new template, then I start with my design neatly on the axes. After some time (different) the empty spaces appear, and as explained I only get them away by completely turning off the PC and turning it on again. Can you indicate with your knowledge of Sketchup whether the hardware of the PC should be sufficient, or is the video card memory too low? Or maybe the video card is broken. If I start another program after the spots such as Acad, Microsoft, Photoshop, the image of these programs is normal and therefore without the spots. When I go back to Sketchup, these are still there.

Thanks again for your advice, greetings Aad.

Thanks again for your advice, greetings Aad.

What does it say when you go to [menu] Window > Preferences > OpenGL > Graphic Card details?
You might wanna try (un) checking fast feedback as well…

My first post was just a guess based on your first screenshot.
If the flecks always appear it would indicate a graphics driver or card OpenGL problem (the other applications you mention don’t use OpenGL). Have you tried updating your driver from the Nvidia website? Have you checked from the Nvidia control panel 3D application settings that SketchUp is set to use your Nvidia card? As Mike says, Fast feedback could be the problem too. For Nvidia graphics, it should basically be turned on.


Anssi, Mike good morning (Dutch time),



I have used the following settings. thanks again for your support. If I need to send more printscreen or infomation please let me know. Question, is the hardware as I have it running now (is standard entry-level HP Game) sufficient to do what I want with Sketchup and SUPodium. I used to use this for my work on another PC, but now with pre-retirement, so it’s a hobby and sometimes a small project.