Edges not vanishing with fog on. Continued


#1

Continuing the discussion from Edges not vanishing with fog on:

This is an annoying subject that has not been addressed. Fog seems to only work with default lines it seems


#2

Can you post a screenshot, elaborating on the issue? I use fog quite frequently but never had problems with edges. Is this a new problem for you or has it been like this all the time?


#3

Ok, without overcooking the issue I attach 3 images of a small domestic project Im working on. The house I do not want to show (with the chimney) is in the rear jpg 1 is no fog with a non default style i like to use. jpg 2 is with fog on - note material gone but edges remain. jpg 3 is with default style which shows the fog working.


#4

I use my own Styles but Fog doesn’t interfere with them. It seems you have a different Style in the 2nd screenshot. I thought the Parallel Projection view might be the problem but after testing it on one of my projects, the fog seems to work just fine.

I might be wrong but I think you have a clipping view on your scenes. To be short, if you have no copyright limitations, could you also share your file so we could have a proper look?


#5

I think this is related to sketchy line styles, correct? It seems that this can be a problem with some graphics cards. The sketchy lines are raster images overlaying the vector lines. They can appear to be in front of the fog. I get different results on different computers. Here on my machine at work, fog seems to have little impact on sketchy lines. It doesn’t fade out the lines like you would expect. It looks better on my computer at home, however. If it’s not already enable, you can turn on Depth cue which will help. You could also adjust the edge color to be a little more gray to heighten the effect.


#6

I never use Sketchy Edges styles, but I wonder if adjusting the Transparency quality in the style settings would have an effect on this, as it resembles the problems that using semitransparent PNG images sometimes creates.

Anssi