Edge Profiles not displayed in Model Thumbnail

This post is directed to 3d Warehouse developers, to call attention to “corrupted” behaviour. When a model thumbnail is generated by the 3D Warehouse (upon uploading a model,) the “edge profile” setting is, apparently, being ignored. What are supposed to be thick lines are displayed as thin, making “stand alone” edges/lines barely visible (practically, invisible):


This behavior is recent, as uploads in October display thicker profiles, just fine:



OK, we’ve discovered some interesting things that we’re working on understanding the 1 pixel profile lines better on the thumbnail generation.

Thanks, Barry,

…for checking. It’s a minor issue, but I did notice the change, due to my regular use of stand-alone, profile-edge “cables.” I suspect that it wouldn’t be noticed by others, and that you (developers) may not have received notice that thumbnail-generator behavior was “quirky,” in this regard.

The post was just a “heads up” for you (hard-working) developers. Thanks for all that you do.


No, we think it’s important that things render correctly. We’re looking at it, and no promises on future work, but we’re aware.

We’ve deployed a new renderbot that is closer to SketchUp’s output. Please look at your models, and report things that aren’t rendered on 3DWarehouse as you see them in SketchUp.


Appearance is restored to the look it used to have…

Tensegrity • 30-Strut

Thanks, Barry! Great job.


1 Like

I have the opposite problem ( that just started today) to the user in this post, the models didn’t render properly after uploading them, showing profiles that I deselected in sketchup and didn’t want to show…
Also when I update a model with another but changing the geolocation of the new one, the geo-location is not updated in 3d warehouse. I had to delete the model and upload the new one with the new geolocation and lost the view/download count, using Sketchup 2017 .

Did you update the style after turning off Profiles?

1 Like

And can you show a photo of one of them attached, and as Dave mentioned, with a saved style? Thnx.

photos for what ?
It is simple, the problem started a day or so ago , look at my previous uploads , all without profiles and look ok.
You are doing something wrong since Google sold Sketchup .
I’ve posted a picture already…of the problem…

Actually it would be you who are doing something wrong.

You didn’t answer my question… but I answered it for myself. You did not update the style after deselecting Profiles as evidenced by the circular arrows displayed on the style Thumbnail.
Screenshot - 10_22_2017 , 9_20_47 PM

The warehouse shows the style you selected. If you make changes to the style and don’t update the style, those changes won’t show in the Warehouse image.

That is to update your sketchup program profile to the model one you just opened in case you want to use it on another project next time , has no bearing on the saved file!
I just uploaded a model with the updated style that on my sketchup was already updated…and the thumb still shows profiles !
So it is a 3d warehouse problem that I didn’t have a week ago!
I’ve attached the screen shot taken before I saved and re-uploaded the model that looks ok in sketchup but the thumb doesn’t render after upload in 3d warehouse…!
Notice the heavier lines of the rendered model on how it appears on 3d Warehouse below and the same model opened in Sketchup 2017 with lighter lines above it

I have the same issue, and agree that this problem has appeared in the last week or so. The Thumbnail generates a level of ‘Perceived Quality’ which is important. Having not seen your thread John, I began another.

I agree…and seen your before and after models…this is in my opinion the incapacity of 3D warehouse software after you upload your model, to cater and render for both scenarios of having profiles on or off in your model and resulting in the thumbnail being heavy…this was done (I’m speculating) to help those people that have the opposite problem where their profiles aren’t marked as much in the generated thumbnail .

Has this problem gone into the box marked “Too Difficult?” - Or the box marked “Don’t talk about it and it might go away!” I have received several derogatory comments regarding ‘Preview Quality’ over the last few days. Even if this issue is to remain ‘Unresolved’ could SketchUP please just say that, in order that alternative arrangements can be made.

I uploaded a Model to 3D Warehouse at 06:00 GMT and the Preview Thumbnails appear to be ‘Back to Normal!’


So maybe you can mark the problem as ‘solved’?:grimacing:

Not fixed yet !

…and after

so stop lying that it’s fixed !

We have now released SketchUp 2018, so you’ll see why this is happening. As you can see, most users are happy as the rendering is more accurate. However, it will be different for different users. I would suggest opening your models with 2018, adjusting style settings, updating the style, and exporting to see what you get. Hopefully, we’re much closer in 2018 than we were in 2017.

1 Like