Dynamic Floor Component Help Please - I'm nearly there

Happy New Year All,

I wonder if anyone can help find why the right edging strip in my model does not position correctly.

A bit of background to the component, I’m creating a platform floor for an exhibition stand which length and depth can be adjusted by the user.
The edging strips always snap to their relevent side and protrude by 0.3cm which is the thickness of the profile.
So a 300cm wide platform would actually be 300cm + 0.3cm left + 0.3cm Right and its start point at 0 would not take into account the edging strip, so the edging strip would be at -0.3cm

They are two standard heights 100cm and 3.8cm which work fine and adjust the height of the edging strips correctly

The edging strips can be hidden, to allow for stock walling to be placed along the edge.

All works fine but the right strip will not position correctly when adjusting the width, but it’s depth adjust correctly.

Please ingone the “Other Positiom” custom attribute, it was something I tried,but didn’t work.

Any help would be fantastic.

Many Thanks in Advance.PLATFORM AND EDGING.skp (549.0 KB)

Happy New Year, @adamb2016,

Your EdgingSetRight component has incorrect axes. Right-click it and select "“Change Axes” to position the axes where they need to be.

Actually, there are a couple other things also…

  1. Missing = sign

  1. No spaces in names. Double-click the name to rename it using _. Then check all your formulas to make sure it got renamed in all formulas that reference this name.

Hi Jim,
Thanks for the quick response, that all makes sense, I’ve made the adjustments and the right clicked into place.
I need to make some adjustments as some of the edging is slightly off.
I’m away for a post Christmas break, but delve deeper when I get back.

One thing I did notice is if the depth of the platform is set to around 100cm the back edging is really out.
Could this be connected to the fact the base model was possibly set as 200cm x 200cm

Many Thanks

It’s at least partly becuase the Back Edge component axes is not where it needs to be for your formula.

Hi Jim,

Just back from my holidays.
Thank you very much for your reply, I’ve progressed further and hopefully narrowed it down to one issue which I’m struggling to resolve.

All edge sets resize correctly when altering the width,depth and height through the component options.
All edge sets are positioned correctly apart from the front edge set in the Y direction, if altered from the default of 300cm and the descepancy seems to be an 0.1cm addition.

The edging strip should always should always protrude from the platform itself by 0.3cm (which is the edging profile)
This works correct on all the other edging sets.

An example of the descrepancy would if the platform depth is Increased from the default 300cm to 400cm the front edge set protrudes by 0.4cm and not the required 0.3cm, this increase of 0.1cm accurs for every 100cm 500cm would produce a result of 0.5cm.

This is also a factor if the platform depth is reduced from the default, so a 200cm depth would produce a result of 0.2cm
The left and right edge sets also draw from this positioning and are therefore “pushed” out by the effect of the front edge set.

One last the the strip does maintain it’s correct shape 1.5cm.

I’ve attached a new updated example and would very grateful of any help you can give.
I just can’t see the wood for the trees.

Many Thanks in advance
PLATFORM AND EDGING to test depth.skp (670.2 KB)

Hi @adamb2016

I can have a look this afternoon. I did notice a few other issues which won’t be difficult to fix. Mostly about getting the component axes in a logic position to make the formulas as easy as possible.

That’s great news Jim, I really appreciate the help.
I tried adjust some of the axis, but may messed it up a bit.:grinning:

Because there is no formula to set the Y position for the EdgingFrontSet. Put in a formula to tell it where to be. It’s Y position will always be -0.3.

Same with the Left and Right Edge Sets.

PLATFORM AND EDGING to test depthv15.skp (251.0 KB)

Thats Fantastic Jim!!
Thank you very much for all your help on this.
I also added the =-.3 to the X position for the front edge set to stop it “pinging across”

Have a Great Day
Adam :smile: