Downloaded doors refuse to scale


#21

Which one did you download? I only saw two arched french doors, and tried both, and neither one has that custom/standard size option. I see the component options, they look similar, but the width, height, are greyed out and there is no way to change them.


#22

I tried a rectangular door. Possibly they don’t do custom sizes of arches because of the required setup to cut the curve?


#23

I looked at Marvin Clad Ultimate Inswing Arch Top French Door 2 Panel. It allows only specific choices of dimensions based on model number selected in the top drop-down list. The displayed height and width track the model number, but you can’t enter your own non-standard values. I think this confirms my notion that they make arched doors only in pre-determined sizes.

It’s been noted earlier in this topic, but I’ll reassert that it might be a bad idea to create concept models using non-standard sizes anyway. You will create the impression that is what the final design will look like, yet you may not be able to find (or afford) doors in the custom size you want!


#24

If you don’t like the dynamic behavior I’ve made a free plugin that converts components to more predictable standard components.

https://extensions.sketchup.com/en/content/eneroth-de-dc-ify


#25

Yes, that’s definitely most likely the case. I tried a window a while back and had this problem, but I didn’t try using the dynamic component, so I will definitely be looking into that in the future if I run into this with normal shaped doors and windows! :slight_smile:


#26

Yeah, I get it, that makes sense for a manufacturer to do that. I’m just looking for something to fill in a doorway in my own model I’m making for my own personal use. I’m working on making my own now. It’s not easy! Just because it’s not for a client, doesn’t mean I want it looking amateur, and my skills are not quite up there yet! :-\


#27

What about:

  1. Select a single component instance
  2. Open in the top menu Window → Ruby Console
  3. Paste this line:
    Sketchup.active_model.selection.first.definition.behavior.no_scale_mask = 0
  4. Press Enter

#28

Given what @drecrego has said about his needs, this might fill the bill. It turns off the scale tool restriction on the DC. Scaling will then stretch everything proportionally, but that seemingly won’t matter much in this case since he isn’t worried about match to any real window.


#29

Hmm… I tried the ruby code, still didn’t work. Still snaps right back to the original size. :frowning:


#30

OH MY GOD THANK YOU!!! :grin::joy:
YOU’RE THE BEST!!!


#31

If scaling was disabled for certain dimensions, there would not be scale handles (so you couldn’t scale it before it can “snap back”). That it snaps back means the dynamic component observed changes and applied its computed size again. In that case one has to remove that dynamic component activity, what Christina’s extension does.