Double click file open - Layout 2018 BUG?

Hi Jeremy, in windows explorer, when you rt click and select Open with… does it show LayOut 2018?

Trent

Yes, it does. It just does not respond.

Thanks!

Hi Jeremy, it looks like you found a bug. I have verified that I see this with both Win 7 and 10 and occurs once the uninstall of 2017 has occurred. It appears that instead of loading the selected file with the double click from Windows explorer it is trying to launch another session of LayOut which we do not allow. Dragging the file from Windows explored into LayOut will open it, but does require the windows to be minimized.

A solution to this would be to not uninstall 2017 but rather delete the 2017 folder under the Program Files after 2018 has been installed.

Thanks for bringing this to our attention and I have opened an issue for it.

Trent.

Thanks, Trent! I have been using drag and drop for my normal workflow and will continue until there is an update.

Thank you for your time,

Jeremy

Hi there,

I have the same problem as described before, while I have not used SU 2017, only SU 2018. What can I do?

Ensure that you have installed SketchUp in the correct way.

In your normal user login.
Close SketchUp [or Layout] if it’s open.
Find the SketchUp installer’s exe file - probably in your Download folder, if you can’t find it download a new installer.
Select the exe file’s icon.
Right-click > Context-menu >
“Run as administrator”
When prompted choose “Repair”…
[If you have uninstalled SketchUp you choose “Install”]
When the installation completes restart SketchUp / Layout and see if it improves…

Installing SketchUp [and its connected Layout app] in any other way will at some point result in all kinds of unexpected and flaky issues - just as you describe.
Being a user who happens to have admin powers is not sufficient.
Double-clicking the exe to run it will NOT give the exact same results as doing it properly.
Also never install an app like this when logged in to the separate ‘administrator’ account - that can produce other flaky behavior…

Hi TIG, thanks for your reply.

I did as you described, however I encounter the same problem. After that, I reinstalled Sketchup, but the same problem is still happening.

Anyone has any ideas on how to tackle this?

The problem described is with an earlier installation of version 2017.

So it is a different problem, I guess?
Have you had an installation of another , earlier version of SketchUp?
Does the drag and drop method work for ya?

Yes you could say so. I don’t have an earlier version of Sketchup installed.

I have the same issues though as described before.

The drag and drop method is working.

I had the same issue as the original poster: double click on Windows 10 would not open a Layout 2018 file if Layout was already open.

My fix was to run Layout.exe as administrator.

I’m unsure why this worked. The original installation was undertaken as administrator.

I only have 2018 installed, however the PC did have 2017 at one point in time. Layout 2017 still appears as an option if I right click open as, suggesting is something amiss with remnants of 2017 or file association.

I have had a similar issue. I can open any file initially, but once Layout is running, the only way to open a file is to go through the open tab in Layout. I have only had Sketchup 2018. Running Layout.exe as admin didn’t work as a fix.

Has anyone been able to fix this? I am having the same problem with LayOut 2019.

Running SketchUp or Layout as administrator is not recommended.
Because this elevates their exe file’s security-level, and then things like drag-and-drop will no longer work, because Windows Explorer always runs at a base security-level, and a lower process cannot affect a higher process.

However, if you have not installed SketchUp properly then running it as admin CAN resolve some permission problems that the poor installation causes…
BUT you are better off correctly installing SketchUp.

It’s possible to ‘Repair’ the installation as well.

Here’s the fix…

Log in to your usual Windows user account.
You do NOT need admin powers, but if you have them it doesn’t matter.
BUT do not log in as the system admin - just use your normal user account.
Close SketchUp if it’s open.
Find the SketchUp installer exe file - it’s probably in your Downloads folder.
Select its icon, right-click > context-menu > “Run as administrator”
When prompted choose ‘Repair’…
When it completes check the Properties of the SketchUp.exe and Layout.exe files in the ‘Program Files’ subfolder[s]… and ensure they are NOT set to ‘always run as an administrator’ under the ‘Compatibility’ tab.

Rerun SketchUp/Layout and see if things improve…

Curiously, knowing I had installed correctly , I went to check the compatibility tab. Run as admin was not checked so…I checked it. Then I went to a layout file and DC’ed and selected another. Both files opened in the same instance of layout. Next I went to SU, Sent a file to a closed layout then sent a second scene. Both opened in the same window under different tabs. Both in '18 and '19

I have run the repair on both versions now and the same problem persists. When I run the repair on the 2019 version the 2018 layout no longer works.

I cant seem to run LayOut 2018 and LayOut 2019 at the same time.

No. That’s true. You can’t. Was that what was hanging you up?

No still the same file problem no change. I thought it was very strange that I can run both sketchup version but not both layout versions.

Yeah. It’s been that way for as long as I can remember and I’ve been using LayOut since the first version.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.