Dimensions seem fine until I export them, unable to 3d print


#1

I made a thing in sketchup that I want to 3d print. When I use the measure tool, everything is spot on. For example, the longest span of the object is 141 mm.

But whenever I try to upload an export (STL, but it also happens without other formats) onto a print webservice, the dimensions are all messed up.

I checked the STL export in Netfab, which says the longest span is 1759.89 mm. When I upload it to 3dhub, it reports a similar 1760 mm. I tried rescaling the longest span back to 141mm (using Netfabb), but with fixed aspect ratios the other dimension are then completely off. Something’s not quite right it seems: both the dimenions and the scale dont export well.

I used the ‘mm’ setting in the STL export dialogue, and tried both ASCII and binary export.

I really look forward to my first 3d printed object, but I need some help figuring this out. Thank you in advance.


STL exports in the wrong unit
#2

The STL file carry no definition of units. So I guess what is happening here is that Netfab assumes the STL units are different from what you export.

However, I just looked up Netfab and units and this article claims Netfab assumes units to be mm:

What are the other file formats you have tried?

Can you share the model in question?


#3

Thank you so much for helping out.

I just chekced again at sculpteo.com. STL en OBJ files seem to upload better than i remembered. The size/scale is a factor 10 reduced, but that can be easily fixed. A .dae file of my object yields starnger values in Sculpteo (longest span is now 5.55 mm), but at least all dimensnions are scaled right and can be fixed.

BUT: it still costs a whopping 128 dollar to print my tiny piece of plastic at Sculpteo. I am eager to find out if 3dhub can do it cheaper, but with 3dhub I have the described dimension problem again.

I have uploaded it. I would be most grateful if you could see a problem with. The dimensions are suppsed to be 141x100x22 mm. Thanks!

phone docker type2 final.skp (158.5 KB)

PS: it’s a wall mounted dual telephone holder


#4

I opened your file, removed Derrick and moved the part to the origin.

Then exported in mm:

I then uploaded to 3dhub, making sure to set the import units there to mm as well:

Dimensions seemed to be spot on.

Maybe because I removed the other stuff in the model and moved it to the origin things worked better for me?

Ditto for Sculpeo:


#5

Holy cow, that did the trick for me too!
This might be the best forum help I ever had. Thank you so much, tt_su.

PS: luckily, 3d printing of my thing is indeed cheaper on the 3dhub!


#6

I guess that the services perhaps took the origin into account. Or maybe the scale figure got included in the export?

Glad I could help. :slight_smile:


#7

This seems to highlight the importance of the Template you start out with. To avoid this in the future, use another template, one without Derrick, or save your own custom Template - File > Save as Template - with all the options preset to optimize the setting for 3D printing.