Dimensions becoming detached in Layout

I have a situation where the layout dimension becomes detached when the model changes. This works okay if I dimension the length of the board in the following image, but not when I dimension the obround.
This image is of the model which has a dimension of 250mm.

This is an image of the layout model. The top dimension is from the Sketchup model and the bottom one is the one added in Layout.
image

If I now change the model, like this

and refresh the viewport in Layout, the model dimension changes as expected, but the Layout dimension doesn’t. i.e. it was not attached properly.
image

When I applied the dimension, I referenced the model arc center
image

and then the second model arc center
image

before placing the dimension.
image

What am I doing wrong?

When I anchor the dimension to the centers of the arcs at the ends of the hole, the dimension remains anchored when I change update the reference after editing the model.

Can you share your LO file?

1 Like

This is the layout file.
Test 1.layout (1.7 MB)

Odd. I can see it in your file but I can’t duplicate it in mine.

I do see that you have the component placed extremely far from the origin considering the size of the component. That doesn’t appear to be causing the problem with the dimension not remaining anchored, though.

I wonder if @adam has any thoughts on this.

Does the dimension appear to be attached okay when you look at it in your Layout?

Your dimension isn’t anchored when I open your LO file. I added a new dimension in your LO file and and when I modify your SketchUp model, I see the new dimension disconnecting.

One option as a work around would be to put guide points at the centers of the arcs in the model and dimension to those points instead of the centers of the arcs. With rendering set to Vector those guide points won’t show in LO.

1 Like

Thanks again, Dave. I’ll look into the guide points and wait to see if @adam can shed any light.
Maybe some unexpected behaviour?

1 Like

Another work around that you could use is to anchor the dimensions to the ends of the arcs. If you want your extension lines to look like you are dimensioning to the centers of the arcs, you can set a negative Extension Line gap distance.

This would probably be a better option than the guide points because you won’t need to worry about inadvertently deleting the guide points when you delete other guides and you can use Raster or Hybrid rendering if needed.

1 Like

Hi Andy,

I haven’t looked at this directly, but the lack of red disconnect highlighting seems to indicate to me that the arc centers don’t have a persistent ID associated with them, which would also explain how come the LayOut dimension doesn’t update when the model is changed. I would definitely have to dig deeper into this to see why Dave’s test works and yours does not.

Adam

1 Like

Just tried this and it works well, Dave. Thanks.
I did have a little trouble clicking the right point, but once I sussed that it is now linked. Again, thanks for your support.

1 Like

I have had a similar experience. We design a lot of products with round tube and there are times when it becomes disconnected and does not show up in red. It is a scary problem as a designer sending stuff into the shop to be built and this happens.

Hi Adam,
Dave has suggested a work around that works, but it’s always nice to understand what is going on.
If you have the time, I would love to understand why it doesn’t work for me.

So from Adam’s remarks it appears that the inferred center of the arcs doesn’t have a PID so when the arc gets moved, the center gets a new ID. I’m guessing that this might get a fix but until it does, it seems the best work flow would be to make sure dimensions are anchored to actual geometry instead of inference points.

2 Likes