Did the 1903 Windows update break SketchUp?

I followed those steps to see what SketchUp modifies. On Mac I could easily see the change it made in SharedPreferences.json. On Windows I couldn’t see the same change, but if I put the Mac change (which appear in the All Computers section of the file) into the Windows SharedPreferences.json file, it has the effect of disabling Ruby that you want.

In SharedPreferences.json, look for the Preferences section. Put this right after that:

    "PREFS": {
        "RubyManager_DisablePlugins": true
    },

So, to include the lines before and after that (so you can see where the important commas are placed), it looks like this:

(other stuff)
“UpdateDefaultOn”: true,
“VCBShowTypedInputBackground”: true,
“VCBTimoutSeconds”: 5
},
“PREFS”: {
“RubyManager_DisablePlugins”: true
},
“SlideshowOptions”: {
“LoopSlideshow”: true,
(more stuff)

I’m lost here, what do you mean “in sharedprefereces.json” it won’t even let me open that file to do any of those things?

My computer seems to have finally updated and so far SU works

See Release Notes for SketchUp 2018, section labeled "Preferences Location".

A JSON (JavaScript Object Notation) file is a plain text file.

For editing a file like this it is recommended to use a good text or code editor.
I use the free Notepad++, but Microsoft also has a free one called MS Visual Studio Code.

Some Mac users have reported (on macrumors.com) that Catalina OS upgrades are taking several hours. Maybe Microsoft and Apple are trying to outdo each other when it comes to painful OS updates.

2 Likes

For the other side of the coin, I updated Win10 just now, took 10min from go to restarted and running.
No issues at all with SU.

I did the beta 4 to beta 5 update yesterday, and it would show 13 minutes to go, 12 minutes, etc. Each minute was several minutes long. Managed to do the update in under an hour though.

SharedPreferences is in a folder inside AppData, which is a hidden folder. But, you can type the full path to get there. Change ‘colin’ to be your Windows user name:

C:\Users\colin\AppData\Roaming\SketchUp\SketchUp 2019\SketchUp\

Apologies for the late response. If you cannot disable Ruby from the console, this is the line you would add to the SharedPreferences.json file:
Disable%20Ruby
Let us know if that helps anything.

You can also just type …

%AppData%/SketchUp/SketchUp 2019/SketchUp

… in the Windows File Explorer address bar (followed by the ENTER key.)

The three lines would be needed:

"PREFS": {
    "RubyManager_DisablePlugins": true
},
1 Like

I encountered the same issue recently. Sketchup gives me a bug splat everytime I open a file or start it at all. It sent a bunch of bug reports, but I didn’t note the report IDs.

It looks like shutting down and restarting my laptop resolves the issue, at least temporarily. I suspect a conflict with another application but I have not figured which one yet.

This behavior is new; it started right around the time 2019.2 was announced, but while still running 2019.1.

This is unusual, I hardly ever experienced a bug splat before.

I am running Windows 10 version 1809 build 17763.615

I wanted to follow up with you guys and give you a summary of what happen and what was done to remedy the problem.

Something happened after the windows update that caused the drivers with my docking station to no longer be compatible… the reason I came to this conclusion was because of the fact that the bug splat did not occur with my laptop not plugged into the docking station to dual monitors. An error would occur previously with dual monitors but it was cured with making sure that sketchup was launching on my main monitor. This caused my IT people to come in and find that when I was using the computer it was not using my RTX 2060 at all once it was going to the docking station… So to fix this we needed to get a docking station that supported a display port and could support the drivers needed for this gaming computer.

That was the problem in a nutshell.

1 Like

I am having the same issue here. We have this happening on 2 congruent systems:

Win 10 Ver 1903
Dell Precision 5530 (Nvidia Quadro P2000 GPU)
DisplayLink D3100 Docking Station
2 External Dell U2419H Monitors
SU 2019.2

If I unplug one of the monitors from the docking station, the bugsplats stop and SU performs as expected. If I plug the 2nd monitor into the laptop HDMI, everything works as expected.

All drivers are as up-to-date as possible.

Any suggestions?

I was helping someone with a very similar situation, only their laptop lid was closed. That left Windows thinking that the Nvidia GPU was driving the main display, but when you went into the Nvidia settings, it said it had no monitor connected. Setting SketchUp to use the Power saving GPU solved the problem.

The person I helped was going to look into how Windows can get into that situation. For the moment you could also set SketchUp to use the Power saving GPU. It won’t perform as well, but it at least will get through the dock.

Please let me know if you see the same symptom, or have any idea on how to make the Nvidia GPU be the one that drives the dock.

Make sure that the Monitor that you launch sketchup in is the "main’ Monitor in the windows settings.If that does’t work it’s a docking station issue. I had to directly plug in my hdmi and display ports into two different monitors to get it to work properly.

1 Like

The dock is USB, which the nvidia has not, I guess, like in a desktop. So you would need an HDMi to USB?

I saw this recently. A report from a gamer who just had his 1903 installation and it apparently resulted in some performance issues. https://www.reddit.com/r/Windows10/comments/d4stns/windows_1903_at_my_wits_end_the_update_completely/

Thanks for the help here as I commented on a similar thread…The work-around for me was to either tell SU only to utilize the Intel Graphics card (rendering the Nvidia useless!) OR opening SU from the ‘built in’ monitor on the laptop, then dragging the window to one of the external monitors. Definitely not a fix, but will work for us short-term. We’re not updating any other systems to 1903 any time soon!

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.