Did the 1903 Windows update break SketchUp?

I just got done installing the latest update for windows and sketchup will give me a bug splat anytime I open a file or start sketchup at all. I’ve tried running repair and reinstalling… Any thoughts?

1 Like

Mine is updating [Win10 1903] as I type…
I’ll see what happens…
Meanwhile check your Graphics Card drivers are up to date and that Windows hasn’t changed things or reset to an inferior Intel GC that might be built-in etc…

1 Like

I got stuck on 11% and finally decided to give up.
I then panicked when my PC appeared to get stuck on “undoing changes”.

Going to hold back on the update

Please let me know how it goes for you.

I am on 183262.267, 1903. No issues here with anything.

I’m stuck at 99% !
Just waiting…

I’ve lost track of how many times I’ve restarted or pressed “Retry” for this update…

Eventually it failed, now trying one Retry, then I give up !

If anyone gets a BugSplat, would you mind sharing the BugSplat ID number? I can look up the issue with that and try to determine the cause. I had been seeing some issues with .NET breaking during a Windows update, but I can’t say for certain that’s what we are seeing… at least until we start reviewing the BugSplats.

Where do I find the ID number? I tried to give that to you in support ticket but could not locate.

Well if you submitted a ticket (which I will look for) then I will find it by the email address (don’t share that here though). Alternatively, immediately after a bugsplat, a browser window should open and display the ID #.

Also, if anyone would like to try an experiment, let’s look at this…
Disable Ruby in SketchUp using these instructions: https://help.sketchup.com/en/disabling-ruby-scripts
then relaunch SketchUp a few times and see if you still have the problem.

yeah but sketchup doesn’t stay open long enough for me to get to those menus.

Windows finally updated itself.
It must win an award for the most painful and protracted update ever !
Then, when I finally go things working I find that it had switched off my Firewall and Antivirus set ups - doh!
And SketchUp wouldn’t load initially - but I put that down to the set up being foobar !
Restarted SketchUp and all is fine :smile:

3 Likes

I followed those steps to see what SketchUp modifies. On Mac I could easily see the change it made in SharedPreferences.json. On Windows I couldn’t see the same change, but if I put the Mac change (which appear in the All Computers section of the file) into the Windows SharedPreferences.json file, it has the effect of disabling Ruby that you want.

In SharedPreferences.json, look for the Preferences section. Put this right after that:

    "PREFS": {
        "RubyManager_DisablePlugins": true
    },

So, to include the lines before and after that (so you can see where the important commas are placed), it looks like this:

(other stuff)
“UpdateDefaultOn”: true,
“VCBShowTypedInputBackground”: true,
“VCBTimoutSeconds”: 5
},
“PREFS”: {
“RubyManager_DisablePlugins”: true
},
“SlideshowOptions”: {
“LoopSlideshow”: true,
(more stuff)

I’m lost here, what do you mean “in sharedprefereces.json” it won’t even let me open that file to do any of those things?

My computer seems to have finally updated and so far SU works

See Release Notes for SketchUp 2018, section labeled "Preferences Location".

A JSON (JavaScript Object Notation) file is a plain text file.

For editing a file like this it is recommended to use a good text or code editor.
I use the free Notepad++, but Microsoft also has a free one called MS Visual Studio Code.

Some Mac users have reported (on macrumors.com) that Catalina OS upgrades are taking several hours. Maybe Microsoft and Apple are trying to outdo each other when it comes to painful OS updates.

2 Likes

For the other side of the coin, I updated Win10 just now, took 10min from go to restarted and running.
No issues at all with SU.