DFX import not working - Import Results empty

RESOLVED
*** Don’t use Emojis :fire: or special characters in the Folder or Parent Folder names where the imported files are stored***

I just updated to the Latest Sketchup build Version 23.1.341 on MacOS and now DFX imports from Adobe Illustrator are not working.

In the past i have been able to convert PDF floor plans, shapes and logos to DFX files to then import and extrude in Sketchup.

Now when i drag and drop the DFX or File/Import/DFX the “Import Results” is blank and then the import fails.

I’ve tried to scour the forum and internet to find a solution:

  • checking the export and import units
  • checking different options on the export and import dialogs, etc.
  • DFX vs DWG
  • Import through File/Import vs Drag to screen

Just last week i was exporting from Illustrator to Sketchup with no hassles or troubles at all.

Thank you for any help!
Attached are some of the files I’ve been trying to import:

Simple test Circle
2nd floor Floor Plan (I know the file is a little messy but that has never stopped the import from being successful previously)

Screen Shot 1
Screen Shot 2

I tried your 2nd floor mezz.dwg and it worked fine in SU2023 on a Windows machine (took a while), but the resultant file is enormous - 25Mb

I sorted it out!

In the parent folder where i have the DFX’s and Ai files there is an Emoji in the File name :fire:… So when the import starts either from drag and drop or File/Import it sees it as a bad/broken directory and stops the import.

Thanks for your response paddyclown!

1 Like