Deep nested Items missing when opening existing drawing

When I started SU this morning I noticed items missing from last drawing that was being worked on which had been saved. These were items that were nested deep in several groups. To keep file size down while working I had created 3 different modules. Was just going to put finishing details into overall drawing (all modules in one drawing) and thought I’d copy and paste mod into o/all to revive the missing items. The items are there in individual mods but when they past in items are gone (2 different mods). Tried to grab just the item in one mod using copy icon but no indication of item when trying to paste (no item at cursor or paste icon available). The other mod worked fine so overall only able to recover 1 of 3 modules. I can replace the missing items with a lot of work that shouldn’t be necessary. Why are there items missing in a file that was saved and why only partially able to copy and paste the items?

Hard to tell from your description. Can you share the SKP file?

Which version of SketchUp are you actually using? SketchUp Free (the web based version) or SketchUp 2017 Make (the desktop version)?

Hi DaveR,

Sorry, I meant to include the ver# 2017 but forgot.

I can share the SKP files (there’d be 3) but was hoping to upload to warehouse only when it was completed.

If they aren’t too large, upload them here. If they are too large, upload them to Drop Box and share the link.

Your profile is confusing because it indicates a version of SketchUp that has never existed.

I guess version was a special ver just for me LOL. But checked out my profile and info displayed wasn’t my doing. Under Lic Type should be Make (desktop) but seems to insist on displaying Free (web). I changed the info but when I went back to verify it was Free again.

Hey, I have to apologize. I thought I’d post this and go off to other things and wasn’t expecting such a quick response. I’ve got a ton of stuff I had planned on getting done today, off schedule already. Didn’t expect troubles to start right off when just taking a glance at SU drawing.

I’m going to have to get back to this much later so won’t be able to correspond until tonight or tomorrow. Definitely something wrong and isn’t copacetic with my drawing or SU but I’ll look at a bit closer before posting again.

BTW file size I’d guess to be about 4 megs which I wouldn’t consider as being big but if you think so could you please provide link or info using Drop Box. I ran across it once but had no need of use then.
I’m not sure how having the SKP files will benefit unless you can reproduce what appears to be an abnormality when using SP.

TIA. Kind of in a rush and may not be thinking clearly while typing this.

Oops! Just noticed I had to scroll down to bottom to save. Thought it was auto save. Profile should be good now.

Your profile appears to show your changes now.

Unfortunately your description of the issue isn’t very clear. Seeing the model can help clarify and diagnose the problem.

As for Drop Box, the best thing to do is go to dropbox.com, set up an account and look at their help files for instructions.

Best way to split a model into smaller parts is to make components of the parts that you would want to open in a new instance of SketchUp, save them by right clicking on the component and choose ‘Save As’ (Choose a location and create a project folder with the same name as the Main model)

For instance, you can model the outer shell of a few houses in a street, save them as components (which can be seen as little SketchUp files inside the main model)

Then edit the saved components to your liking ( notice that the outer shell of the house is now just a collection of faces and edges) save when done.

In the main model, rightclick on the component and choose ‘Reload’ navigate to the folder and choose the edited file. (Or any other…)

1 Like

What you describe is typical of trying to copy/paste from a newer version of SU into a older version.

Your profile indicates you’re currently using SketchUp Make 2017
Do you recall installing a 30-day trial version of SU Pro 2018 or 2019 ?

Hey guys, thanks for your input.

DaveR - I figured out what caused the problem. User ignorance.

What happened was I put a personal notation on what I thought was an unused layer, but it wasn’t, and of course when I turned the layer off the other items turned off with it. Not sure about this but it appears that when an item is copied that’s in a layer on another drawing the layer gets copied also.

MikeW - This sounds intriguing. I haven’t found much use for components yet. I’ve tried but always seems when I make an item into component for repetitive items each item tends to be just a bit different and I end up making them all unique. Can see where using component could save time not having to redraw each time and also using them for repetitive items keeps file size smaller. Perhaps some day the light will come on and I’ll find the advantage using components but I’m going to keep your suggestion mentioned here in mind.

Geo - Yep tried both 18 and 19 but uninstalled both when expired. My biggest regret was trying the Free (web) version. I thought I had to install Trimble Connect along with it. Big mistake. Really bogged down my laptop and even after uninstalling machine still doesn’t perform as well. As far as SU 18/19 goes I only have one drawing done in 19 which won’t open now without having the newer ver. installed. I did triy an experiment prior to expiration though to see it was possible to convert a newer SU ver. back to an older ver. and had great success. Apparently can convert back to any ver as necessary.

have a look:

house

and then:

house1

MikeW - Not quite what I envisioned from what you originally described. But you’re just a step away from the point I was trying to make about using components. Now add some windows. They generally aren’t all in the same location or of the same size. And doors aren’t necessarily in the same location either. To fix that all I know of is to make the components unique. Otherwise what you’ve got here is " . . . all made out of ticky tacky and they all look just the same . . . " with respects to Malvina Reynolds