Decreased mouse function on extended display

I just added a second display to my 2019 Macbook pro, primarily for added display space while using sketchup. However the mouse has limited functionality on the second display. I am able to select things from sketchup menus and tool bars but I can not interact with the model I’m currently trying to work on. This issue seems to be specific to sketchup as I seem to have all mouse functionality with other applications in the second monitor. Please let me know if you have any suggestions. Thanks
Erik

Did you move the SketchUp window to the other monitor? (How else😃)
Upon startup, SketchUp looks at the active monitor dor internal settings (pixels, dpi, etc)

Try maximizing on the other display, then under [menu] SketchUp > Preferences > Workspace hit ‘Save current Window’
Quit SketchUp (through the File menu)
Open SketchUp.
Does it improve?