Decals in Mac OS


#1

I am using Mac OS Yosemite I am trying to place a decal on an object. I can only find how to apply it as a texture and thus when I rotate the object, the decal doesn’t move with it.
Does this feature not work on a mac? How do I do it?


#2

Textures move and rotate with the objects they’re painted on. I’m not a Mac user, but I can’t imagine textures working differently on the two platforms.

Why don’t you back up and tell us more about this “decal,” which at this point could be anything. Is it an image? Do you have it in vector format? Would you prefer “cutting” the figure depicted by the decal directly into the skin of your model over a texture?

Your description of a texture staying still while the object it’s painted on rotates makes it sound like like maybe you have trouble working with textures. Please tell us how you went about applying a texture that behaved that way.

-Gully


#3

As Gully says, once you have a material (“texture”) created, there is no difference in how it will behave on Windows vs Mac. Did you import the “decal” as an image rather than creating a material from the image? That could explain what you are seeing.


#4

A texture does not move with the object as long as it has just been applied, but not “positioned” (anchored). Try on a single selected face right-click → Texture → Position, then accept with enter or by clicking into empty space.

Another possibility for textures not moving is when you have only edges selected and move the edges.

Gully is right that for solving a technical problem, it is necessary to use precise vocabulary. It’s relevant what type of object/entity it is, not what it represents. The same texture problem can be solved no matter whether the texture represents a decal, a painting or kitty wallpaper.


#5

It seems when it comes to materials, there is a significant difference between the Mac and the PC. If you look at the SketchUp user guide at Materials, you see that there are different categories for each.
Here are some screen shots. Also you can see what happens when I right click. It’s not the same as Windows

It will only let me post one image at a time since I am a new user… So, I will have several replies.


#6

Here are the rest of them, again since I am a ‘new user’ to this forum, they are only letting me post a few posts within a certain time so …


#7

I think @Aerilius probably nailed it. I just tried what he described (on a Mac), and it worked as described. You just have to be sure you selected the Face with the texture on it before the right-click will have Texture on the context menu.