Cross Reference Organizer

I’ll ask Andrew, our developer to reach out to you.

Thanks. Wait though, until I’ve checked if the model is just overwhelming SU with all that geometry ‘on’.

I think that’s the problem. Force Quit from CRO update, reopened model, and tried a few simple operatioins - v sluggish, then the beach ball when I tried to delete a third scene (first two went quickly).

Then even typing in this post started stuttering.

Time for a machine restart, I think.


instal menu meters, and don’t go to the next big SU action till the cpu meter settles back down to < 10

SU has quite a lag from when it ‘looks’ like it’s settled and when it actually is…


Thanks, will try that tomorrow (well, later today, but after a nights sleep!)

I’ve restarted my machine, turned off all layers except the Cross Reference ones and Layer0, and deleted a few unneeded scenes. The model’s manageable again, and I’m just updating a new scene with this minimal layer set ‘on’.

Just about to try CRO Update again.

Drat! Forgot to do a Save first, to preserve the new layer state in the new scene in case the import freezes again (not using Layers Organizer yet in the model)

I’ll leave it running while I have a bath.

John, a good test is to do a File/Import and see what happens - if it is almost as slow, then it is underlying SU processes rather than the plugin.
What are menu meters? (Is that a Mac thing?)

I guess so - I’ve not heard of it though.

And I will try a plain Import if my second attempt tonight stalls indefinitely, or leave it running overnight and see.

yes, it’s a useful mac utility for watching system processes in the menu bar at top of screen…

it’s now open source and the version I run can be found at

MenuMeters for OS X El Capitan 10.11 and later


Well, I don’t know how long it took because I was away from the computer for at least an hour and a half, but I finally got a result - ‘Successfully updated’ message from CRO.

Click OK on that, and WAIT beachball again for a while. Still waiting after another minute or two.

Or three or four…

FINALLY got the cursor back. Saved. Uploading to Dropbox now - usually takes another 5mins or so - it is a monster model.

Thanks JQL for your questions - in fact you’ve given me an idea for extending the functionality of the plugin. I’ll explain the idea at the bottom.

First, to respond to your post:
Edit: It’s difficult to be sure I understand you perfectly - and it may be better to discuss over a series of emails - feel free to contact me on I hope my lengthy response does not bore others.

We might be working with different definitions of an xref.
In our way of thinking, if you are working/modifying the windows inside your working file, then they are not references - they are part of your working content.
(When you say you export them out into another file and sit them with a bunch of others, I’m curious how you get them all into one file - do you save out a component as an .skp, and then File/Import it into the file where the rest of the bunch are?)
We are working on our own workflow, but I think to achieve your ends we would do the following:

  • Use File/Import to introduce a window assembly from our Component Library into the working model. (On the other hand, if we originate the window assembly in the working model, then we would make a decision to promote it into the Component Library from where it can be used elsewhere.)
  • At this point, it becomes part of our content in the working model. It is not a Cross Reference. We could could modify it uniquely here, or modify the Component in the Library and Reload it here.
  • Then, if the working model is needed as a Cross Reference elsewhere, it can be managed from there using CRO.
  • If we want a file containing a bunch of different window components, they would be version controlled by being File/Imported there - either from the working model or directly from the Component Library.

The idea:
The problem with Imports is that it is hard to see what has been imported and - perhaps more importantly - if the Import is up to date with the original content or needs a Reload.
We could extend the functionality of the CRO Plugin to manage File/Imported components in the same way as Cross Referenced components - that is, place them in a list with colour patches to indicate update status.
Would this be useful?

This plugin Eneroth Component Replacer looks like it can do search and replace on components:

Yes, I understood your way of thinking. Mine is different in that regard as I have a working model or several side by side, as you do, but then I have a lot “sub-models” that are also working models. It makes no sense to make them Library components to me as they are usually unique from project to project. Parts of them are in my libraries but not the whole model.

They are unique per project so I start by creating them in my working file and work on them up to a point that I export them for collaboration and reload them when they are updated.

So, I have the working model just as you do, and several subreferences that I also have to keep updated. It’s a bit of a pain updating them but we can manage. It would be very useful to us if we had something like your plugin that could help us manage them too so:

That would be EXTREMELLY useful and it would make me droll for the plugin.

This is a scheme of how we manage our xrefs around here. A plugin would really help, but it’s not as complex as it seems as all the complexity is growing with the project and usually a project can be handled by 1 or 2 persons:


Just to let you know, @Yorg, that after my severe troubles and very long delays last night trying to use CRO to update the main model with changes to one medium sized submodel, two updates this evening went like a charm - a couple of minutes, and all done.

I think my problems were several last night:

  • I’d been editing a very large model in SU with too many layers turned on, for too long
  • I hadn’t restarted SU after it started to show erratic behaviour and respond very sluggishly, but ploughed on
  • I should have saved the model before trying to update the submodel CRef
  • I should have set up a scene where the minimum possible number of layers were ‘on’ in the main model, before running the update

Once I did all of those things tonight, it all worked smoothly, as it should and normally does.

Much appreciate the clarification.
Cheers John.

Could you please send a high resolution copy of your diagram - I can’t read anything on it.
Send to
I will look more closely at your most recent reply and talk with my developer to see if we can leverage what we have already done.

Have you clicked on the file here at the forum? It opens up to a readable full size version. Anyway I’ll send it asap.

… and you should be able to right-click as save locally to your machine, and then open in any graphics viewer you desire.

P.S. - When the mouses hovers over it, we can see that it is 1726 x 1261 pixels.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.