Creating scenes with content only contained in a specified layer


#1

When I create a scene I also create a layer with the same name. A given scene will only show what is in the layer of the same name. This process insures that when I insert a scene into layout I know exactly what will show up. When I create a new layer, I start with all the layers except layer 0 turned off, then create the new layer. The problem is this new layer now shows up in all of my existing scenes and I have to go back and refresh all the scenes with the new layer hidden. Is there a way around this?


#2

Unfortunately this is the default when making new layers with the native tool.
Use Jim’s Plugin http://sketchucation.com/pluginstore?pln=jf_add_layer
Then the new layer will only be visible in the current scene-tab and it should not be visible in any new ones, unless of course you switch it on manually.


#3

Thanks for your help, I was afraid that was the case. This leads me to next problem, I have had zero success with plugins because I always end up with the “can’t open rbz files” message. Can you help me with that?


#4

Are you trying to open the plugin file using SketchUp’s File->Open? If so, that isn’t the way to install a rbz! Instead you use the install button in the Preferences->Extensions window. A rbz is not a SketchUp model file, it is a compressed Ruby archive.

http://help.sketchup.com/en/article/38583


#5

You do not need to “open” the RBZ.
Provided that your SketchUp is v8.2 or newer*** then you ‘install’ the RBZ, thus:
Open SketchUp’s Preferences [PC it’s Windows > Preferences, MAC it’s SketchUp > Preferences]
Open the ‘Extensions’ tab and click on the ‘Install Extensions’ button.
Find the RBZ and OK, accept the various dialogs and the the RBZ Plugin has been installed in that version of SketchUp.
Usually it immediately available for use.
But if it’s not, then restart SketchUp to complete the installation.
Most Extensions are initially loaded ‘activated’, but check that in Extensions if you can’t find it.
Some Plugins are not made as Extensions and these always load.
Plugins work in a variety of ways, read their usage notes…
Many appear in the Plugins menu [aka Extensions in v2015].
But some appear in Tools, Draw etc.
Some appear in right-click context-menus depending on selections etc.
Others have Toolbars which might need activating too.
A few are run from the Ruby Console by typing in a command,
Note how some Extensions also need a supporting ‘Lib’ of helper files installing separately - e.g. Fredo’s and Thomthom’s toolsets…

In the case of the Jim’s “Add Layer” tool, it is a relatively simple thing…
The Extension makes an entry in the Plugins [Extensions] menu and opens a self-explanatory dialog with which you can set up how the new layer interacts with existing/new scenes…
See ‘More Info’ in the PluginStore download…

***If you have an earlier version I must urge you to get up to date…
Failing having a half-recent SketchUp version, then you could convert the RBZ archive back into a ZIP file - by editing its file-type suffix to .zip - then extract its contents into the relevant SketchUp folder, keeping files within subfolders intact…
To open your Plugins folder use this snippet in the Ruby Console + (enter)

UI.openURL("file:///#{Sketchup.file_support_file('Plugins')}")

By now you will have realized that installing from a RBZ is MUCH easier - that’s why they were invented. :stuck_out_tongue_winking_eye:


#6

Thanks for all the help, I have just successfully completed my first plugin download!


#7

You can also try this plugin - http://extensions.sketchup.com/en/content/auto-invisible-layer