Crashing app when I change nr. of circle segments


#1

I can reproduce an app crash when I double the amount of segments from 18 to 36. I can send you the model if you’r intersted.


#2

Have you submitted the BugSplats to Trimble including details of what you were doing and how to contact you? They will definitely take a reproducible crash seriously.


#3

Does it not crash if you pick a higher number of segments?


#4

What version of SketchUp are you using? If SU2015, have you checked to see that you have the current revision. I have a recollection of an issue like this with the first release but it was fixed in a maintenance release.


#5

What SketchUp version and what OS are you using? If you can attach the model that would be very helpful.
(Edit, I’m just an echo of @DaveR…)


#6

It’s because of the hat. :grinning:


#7

How & where can I do that?


#8

OS = 10.10.5 Sketchup Make v.15.3.329
I would have uploaded the model but I see no option to upload a binary in this forum.
Meanwhile I fixed it.
But I had to build it many times over in order to circumnavigate the fatal errors.
Changing the nr. of segments in a circle or arc is very risky.


#9

Edit your profile to include OS and SU version number.

Just to the right of </> above the text window is the button for uploading files.


#10

Here is how I can crash the app. I open the attached model. Then I make this change: http://www.screencast.com/t/9ZmVs4rHTyo
Expected result 6 segments changes to 12.
Actual result -> Crash

Untitled3 - dimensions.skp (122.9 KB)


#11

When SkecthUp crashes, you should see a window pop up with a BugSplat label, fields to type in what you were doing and contact info, and a button to submit the report to Trimble. I think I recall some reports of people getting crashes without BugSplats, but I thought that was fixed in one of the 2015 maintenance releases. 156.3.329 is the most recent on Mac, so that isn’t your specific issue…However, if you aren’t seeing the BugSplat window, that may be a clue.

Your profile says Intel HD Graphics 4000. There have been various reports of problems with the OpenGL support on the Intel integrated graphics. Try turning off hardware acceleration in SketchUp preferences and see if that makes the problem go away (this is mainly a diagnostic test, as it will make SketchUp’s UI sluggish on anything but very simple models).


#12

Is what you uploaded the already repaired model? I can’t find an arc with 6 segments at the area shown by your screencast.

I don’t know whether this affects the crash, but you are working at a very small size (mm sized entities) that is almost certain to run into problems with SketchUp’s nearby vertices tolerance. I recommend that you scale the model up by a factor of 1000 (work in meters) while drawing and scale it back down to mm when you are finished.


#13

you need to supply the same model as your image for others to test…
the skp you attached is really badly made and has lots of used materials, etc…
and as steve mentions, it’s all very small…

john


#14

Oops. Sorry. This is the correct one.

model with segment bug.skp (93.0 KB)


#15

OK, I also get a crash on that model. I submitted the BugSplat (still don’t know why you didn’t get one…).

When I scale the model up by 1000 the problem goes away, so it seems very likely there is a bug affected by small geometry.


#16

I’m designing a small trackeable tag. So i’m working with shapes of several milimeters… I did see a bugsplat icon popup. But I didn’t know what to do with it.


#17

For your future reference, SketchUp has a tolerance built into many operations to avoid issues with computer arithmetic. When an operation calculates vertices closer together than about 0.001" (0.0254mm), SketchUp may conclude they should have been the same and merge them together. The problem isn’t with ability to have vertices that close, it is a trap for possible computer math issues in operations that calculate positions. So, when you need to do a small part, the best way is to draw it at some exaggerated size (e.g. using meters instead of mm) and when finished, scale the whole model down to the real size. You can do this by measuring an edge with the tape measure tool and then typing its real size (including units). SketchUp will ask whether you want to scale the whole model. Click Yes.

However, in your model there is some critical glitch that is tripping a real bug in SketchUp. The glitch may have resulted from drawing at small size, but could also be something else. The Trimble team should be able to figure it out given the model, my BugSplat, and the fact that it is reproducible.


#18

I can also replicate the crash, even if I copy paste the geometry in a new model [ to avoid all the unused content ]

It actually appears as a text input error…

@Barry, this seems like a reproducible bug…

john


#19

@slbaumgartner & @Barry, interestingly you can change the number of segments to 12 using ruby without upscaling…


again that points to a text input error…

john


#20

Yes I noticed. Some numbers are fine. Other numbers will kill the app. I found no logic behind it.