Crashes (no bug splat!) and System Resources look fine_What's happening?


#1

I’ve just come up with something that I think is pretty cool and I definitely want to use it…but i can’t.

There’s quite a bit of geometry there but it’s only in a beginning/test phase. No building as yet!

When I attempt a Preview Render it works (Podium).
When I turn on Shadows it crashed (of course. lots more going on).

But looking at my System Resources in real time, Processor is on 10-15%. RAM 39%.

Is it my Graphics Card? (NVIDIA GeForce GT 620)

Is this a familiar story to any of you?

I’m Mark, by the way. My first post.


#2

(1) Make sure your Nvidia driver is up to date, …

(2) … and that SketchUp is set to use the Nvidia GPU in the Nvidia Control Panel.

(3) Make sure Podium is the latest available version.

(4) Purge the model of any unused components and materials.
Window > Model Info > Statistics > Purge Used


#3

Thanks Dan,

All is up to date and Purged.

I’m not exactly sure what you mean by point number 2 though. I have Open GL selected in Sketchup.

I’m unaware of any ability to select Software within the NVidia Control Panel.

Thanks again,

Mark.


#4

It’s a shame I can’t see my GPU performance in Win 10 Task Manager.


#5

Conclusion so far.

Correct me if I’m wrong but My NVIDIA GeForce GT 620 isn’t coping with the heavy workload of my Sun Shadows. Working with the model without shadows is no problem at all.

A couple of Model Info stats:
Edges 104, Faces, 27, Component Instances 10.

Show Nested Components:
Edges 1283571, Faces, 458132, Component Inst 559, Groups 2497.

I need to sort this in the next 24 hours. My budget is a bit tight (I’m a student, living alone) but I’m seriously considering a Graphics Card on my credit card. Or this idea is out the window.


#6

Hi Mark and welcome to the forum.

How much is “quite a bit” of geometry?
Share a screenshot of Model Info - Statistics

Learning how to manage model complexity will help all your models perform their best.
See:
How do I make SketchUp run faster? — SketchUp Sage Site


#7

With and without “Show Nested”.


#8

Quick & dirty test - if you’re running the 64-bit version of SketchUp, try the 32-bit version. And vice versa. They will exercise different versions of your video card driver.


#9

Your model is in my terms quite enormous, with over a million edges.

What Dan means is that if your computer is a laptop (like mine with a Nvidia Geforce GT 620M card) or has a motherboard with an Intel chipset, you might have an Intel display chip in addition to your Nvidia card. Then you should open the 3D Applications section in the Nvidia control panel and check that 3D applications, and, if you want to be specific, SketchUp are set to use the Nvidia processor:

Here, the Automatic selection is not enough - it favours the intgrated graphics to save power, and integrated graphics do not work well with Sketchup.

Anssi


#10

There is some , when you have the T/M performance tab sleeted look at bottom left you should resource resource monitor it has a number of items you can look at and allows wait chain analysis, cpu , memory disk, network etc views.


#11

I like your suggestion.

I don’t see any 32 bit version in the x86 folder.

You mean a fresh install on top of 64?


#12

Right. Thank you Anssi.

I haven’t had Maximum Performance selected.

I’ll give it a go.

Are there any other tweaks I should be looking for here?

It’s funny. I’ve recently come to Graphics after many years in the “Pro” Audio world, so I’m pretty green in regards to this stuff.


#13

You shouldn’t need other tweaks. Especially, the recommendation is that you keep Antialiasing and Anisotopic Filtering at their default “Application-controlled” setting.

Anssi


#14

Cool. Thanks again for pointing me in the right direction.

Changing the setting allowed Sun Shading to think about engaging for a while, before crashing again. Not so surprising. I’m adapting the size of my apertures for the moment, reducing geometry.

I’ve ordered a 1050 card and some more RAM. RAM has been on my list for a while, as exporting to Podium OOPR would often crash juuuust before making it to render.

I’m hoping the 1050 will allow me to interact with my model in a smoother way, and keep me working with this facade concept.

It’s a shame Podium won’t benefit greatly with the new GPU and increased CUDA processors but I’m not about to go and invest in VRay. So far I’d say Podium is remarkably good value. I wish I had a second machine to test the beta server thing they’ve got going at the moment. But rendering is not the be all and end all. I’m finding that Default quality renders are good for most things when the building/frame/lighting is right. My main frustrations come from interacting with a ‘heavy’ or laggy model.