Crash & Rectangle Dimension Issue in Sketchup Trial Version on MacBook


#1

I am working in a trial version and have been experiencing issues of crashing once I got to the creating floor plan stage. I can import my floor plan OK however, when I create a rectangle to begin copying the floor plan in Sketchup, my room dimensions are super small, too small to work in. For example a room 23’ x 16’ is almost undetectable at the origin point. I can maximize the zoom but this makes using my imported plan impossible as it becomes too big. The crashing has occurred when “clicking” at the end of making the rectangle. I’ve uninstalled and installed twice, called Apple (they can’t help because it is a 3rd party software), I’m stalled out. TIA


#2

In what format is the floor plan you are importing? How are you going about importing it?


#3

if importing DWG/DXF data select the correct unit used by the creator in the “Options…” dialog of the import window:

https://help.sketchup.com/images/su-3000165-import-options-1.png

After the import, right-click an edge with a known size and check the true length shown in the Entity Info:

https://help.sketchup.com/images/fg019_4.png


#4

jpeg format. Importing from my saved docs.


#5

OK. SO after you import the image, you have to adjust its size to be appropriate for the model. There is nothing in the JPG file that can tell SketchUp how large it is supposed to be.

One way to adjust the size after importing the image is to use the Tape Measure tool to measure a known line in the image. Hold Option while clicking the second end of the line. Then type the dimension it’s supposed to be and hit enter. SketchUp will ask if you want to resize the model. Click Yes.


#6

They were sent by the designer in pdf format. I converted for the purpose of Sketchup to jpeg.


#7

Yes I’m doing this, using the tape measure as well as typing in the measurements in the dimension box. A room 23 x 16 is almost dot like. I rechecked the measurements using the tape measure and the dimensions were confirmed as accurate. Something is not right, like something is conflicting with this program.


#8

But, it isn’t the imported plan that I’m having an issue with, it is the “rectangle” that I create to use to begin my new floor plan within Sketchup? Am I making sense?


#9

How about uploading the SKP file so we can take a look at it? If you don’t want to make it public, send it to me as a private message.


#10

Screenshot


#11

How about uploading the SKP as I asked? Why is the image so far away from the origin?


#12

I “moved” the imported plan as to make room for my rectangle. It isn’t the import that is causing a problem because when I try make a rectangle of any room size, it’s way too small.
Still want the file?


#13

Yes. I still want the file.


#14

W Franklin St Floor Plans.pdf (300.7 KB)


#15

No! Not the PDF. Upload the SKP file. The SketchUp file that is giving you problems.


#16

I don’t know what you mean, upload a Sketchup file? I just started this Saturday, give me a break…


#17

I am giving you a break. The SKP file is the saved SketchUp file. It has the extension SKP.


#18

I guess this happens when I actually save a drawing? Haven’t saved anything yet.


#19

Yes. You get the SKP file when you save. Do that now and upload the resulting file.


#20

Saving the model will create a file with the extension .SKP. Upload that file and we will be able to see exactly what you have going on.