Crash on explode group (of imported .dxf)

Hi everyone,

I’ve been having problems with editing this SketchUp file. It crasshes when I try to explode, scale or draw within it’s grouped content. I intend to use the CurviLoft extension to fold this pattern into a cylinder shape.

Work has set me up with a new pc so I have no idea where exactly the problem is.

I’ll update my pc specs on my profile but here’s a list for now:

HP Z Workstation

  • Windows 10 Pro (Version 21H2)
  • Sketchup 2022 Pro (latest version, 64-bit)
  • Intel i7-10700 2.90GHz CPU
  • 16.0GB RAM
  • Nvidea T1000 (4GB, up to date drivers)

I’ll also attach the file I’m trying to work with.

Does anyone have any idea why Sketchup keeps crashing when I touch the group?

Krakelee-.dxf (2.0 MB)
Krakelee Project.skp (2.3 MB)

If you use Fredo’s Curvizard to simplify the edges it will work.

I am trying to use this plugin but it renders my pc almost non-responsive, it doesn’t crash though… Yet I don’t think this is the solution I’m looking for, I suspect it’s hardware related?

EDIT: it seems your solution works but I still find it strange I have to use these steps in order to work with the file at all… I doubt things will go smoothly when I try to bend this shape around a cylinder…

There is a huge number of segments in the file and it will take time to work through all of them.

So it’s just the enourmous amount of segments in the file (I saw them highlighted when curvizard was done)? Any idea how I can prevent that from happening in the furute when importing files?

It’s a .png converted to .dxf on convertio.co, then imported into SU if that helps

No idea, there may be some way to set the complexity when you convert the png.

Alright, thanks for the quick response (and a working suggestion)!

Here you go, just so you know it can be done. I used Thomthom’s Truebend to make it into a cylinder.
Cylinder

1 Like

MODELSPACE.skp (1.8 MB)

SketchUp keeps crashing when I try to bend this with the Truebend Plugin, any ideas how to not crash SketchUp?

That is not a lot of memory by contemporary standards. You might run Task Manager and monitor how much memory is free while running this operation in SketchUp. If memory becomes mostly full, try exiting out of other applications in order to allow SketchUp to access more memory.

When you say crash, do you mean the program shuts down and you get a bug splat?
Or do you mean the shape turns red and it appears to do nothing?

Here it is for me.

Program is slow, takes a while to see the red shape you mentioned. When I press enter or left click > commit it takes a second to crash the program. About half of the attempts resulted in a bugsplat, otherwise just a crash to desktop.

I’ve ran another attempt with the Task manager open, the memory usage didn’t jump up but rather dropped by 0,1GB.

current usage is 4.0GB out of 16.0GB

What is the finished result you are after?
A solid cylinder with raised pattern?
Or a hollow tube with the raised pattern?
Or a tube with some thickness and the raised pattern?

Either one of those, one with a raised pattern and one with an indented pattern.

I wonder if some other extension is monitoring the editing session within SketchUp (via observers, for example) and is causing the crash. You might try using the Extension Manager window to disable all extensions (or all except the one or two you are using during the action in question), exit and restart SketchUp, and try the operation again.

Did as you said but got a crash all the same…

Sorry, got called away.
I chopped this in half and gave it separate back plates. Then bent them as pairs. This gives you four solids to work with.

I’ve added the file for you with both before and after the bend.
MODELSPACEbox.skp (2.3 MB)

While I appreciate the gesture, this doesn’t fix my problem… I’ll have to make more of these in the near future.