"Could not create texture materials"


#1

Every time I import a 3ds file into Sketchup Pro 2017, I always get an error message that reads “Could not create texture materials…” The full error message is

3ds Entities Imported
Materials: 5
Nodes: 7
Meshes: 6
3ds Errors:
Could not create texture: pm0146_00_Body1.png

Could not create material: Texture_0_0
Could not create texture: pm0146_00_Eye1.png

Could not create material: Texture_1_1
Could not create texture: pm0146_00_FireCoreA1.png

Could not create material: Texture_2_2
Could not create texture: pm0146_00_FireCoreBC1.png

Could not create material: Texture_3_3
Could not create texture: pm0146_00_FireStenABC1.png

Could not create material: Texture_4_4

When I Google the message, ONLY results dating back 10 years ago showed up. There is NOTHING regarding this error message in Sketchup Pro 2017.

The 3ds file IS in the SAME folder as the textures but still get this error message.

Does anybody know what the problem could be?


'Importing and Exporting 3DS Files' help page is missing
#2

Does the folder containing the 3DS file and PNG images [and its contents] have full read/write permissions set up?

When you installed SketchUp v2017 did you right-click on its installer exe file and use the right-click context-menu “Run as administrator”

If not, close SketchUp, do as directed above and choose to ‘Repair’…

That might fix it - some flaky [and subtle] things can happen if it’s not properly installed…

Can you open the PNG files in a Browser ?
Cane you open the PNG files in Photoshop or Gimp etc ?


#3

I can open the PNG files in Windows Photo Viewer, I have not tried Photoshop.

The installer ran itself as administrator, the UAC popped up when I installed Sketchup

This is Windows 7 64-bit btw


#4

It’s not the same just to be logged in as an administrator, you need actively to select ‘Run as Administrator’ when running the .exe installation file - R-click on the file, and choose that option.


#5

There is no ‘run as administrator’ option on the installer when I right click it. just a ‘Install’ ‘Repair’ ‘Uninstall’


#6

No, that is the next step.
Before running the installer, do the right-click and choose “Run as administrator”… then ‘Repair’…


#7

And if you still don’t get ‘Run as administrator’ as an option, are you logged in as THE administrator? If so, you shouldn’t be for normal use.


#8

This topic was automatically closed after 91 days. New replies are no longer allowed.