Corrupted model - can anyone help rescue it?


#1

I’ve drawn this model for 3D printing, 1000x scale size.

Somehow, the model has become corrupt. I can open it, but if I try to select it, scale it, or just copy it to clipboard, I get an immediate bugsplat - repeatedly.

I have tried saving a copy, hoping that might clean it up.

I have tried saving it as an older version (2016) and reopening it in 2018. I cal now select individual subcompoents, but again, it bugsplats immediately I try any operation on it.

I have tried saving it as an older version, then opening it the older version (2016 again).

Again, I can select all, and choose the Select tool, trying to scale it down for printing. But as soon as I try to move the Scale tool handle, it splats again.

Can anyone help me recover a usable model? I’d rather not have to draw it all over again!

M6 Hex nut aperture sizing x 1000 copy.skp (1.4 MB)


#2

Is it only the part in your image you need?
If so try this.
M6 Hex nut aperture sizing x 1000 copyBox.skp (454.4 KB)


#3

Yes, just that part. Either this size, or scaled down by 1000x to millimetres.


#4

Brilliant.and MANY thanks.

How did you manage it?


#5

It worked fine for me out of the box. But I purged 48 components from it and saved it.


#6

Thank you so much. I didn’t even think of trying a Purge, and should have.

But when I do the same as you did on my original, or the copy I uploaded, it still splats every time I try to scale it.

If I were on a PC, I’d try a reinstall and repair, but I use an iMac and I don’t know of an equivalent.

Should I just reinstall from scratch?


#7

in v18, delete the two hex bottoms, use ‘outer shell’ and export using mm…

no need to scale…

M6 Hex nut aperture sizing mm.stl (239.9 KB)

john


#8

When it comes to Mac I know nothing.


#9

Another solution that works.

Thank you, thank you. I might use that regularly, as it is a simpler workflow than the scaling.

Any idea what might have happened in my original file? SU said ‘No problems found’ when I ran Model info/Statistics/Fix problems.


#10

Except that it doesn’t seem to work for me. I change the Scaling setting in Options to mm, and export, but it comes back into SU imported as STL, and is still 150m long, not 150mm.

Will have to resort to scaling again before export.


#11

I see the crash - I’ll file a bug to have someone investigate the underlying issue. (#38455) Thanks for reporting.
-m


#12

Thanks. I wasn’t aware of doing anything unusual, nor (as far as I remember) using any offbeat plugin. Tried Editable 3D text, but used the native tool in the end, I think. And TIG Mirror.

For the rest, native tools I think.


#13

I’m a Mac user.
If you can’t even open a SketchUp file without a bugsplat one thing that sometimes works is duplicating the file (right click/Duplicate) and changing the file name in the Mac OS before trying to open it again.
Sometimes…
Purging is always useful if you can open it but it splats when you try to do anything.


#14

Sorry this response is delayed, but I wanted to give an update here. I was assigned to look into the bug (#38455) Marc wrote up from a testing perspective. I can reproduce it on the Mac, but not on Windows. And if I save your original model on Windows (without doing anything like purging the model) and open it up on the Mac, the crash goes away. Which is strange.

The crash seems to be isolated to the rectangular “Base” component definition in the model - exploding that component and recreating it seems to be a workaround for me. Do you remember how that component was created?


#15

As far as I know, I drew a rectangle on the red/green plane, then pushpulled it up.


#16

Got it. Thanks for the reply.


#17

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.