Corrupted Autosave File

I was working on a file for several hours. Then, it suddenly freezed and I had to close it, I was sort of selecting a component. I checked my folder and found the original file the backup file and the autosave. the problem is the autosave file is the only updated one, but when I try to open it sketchup takes too long to open and then crashes immediately.
the weird part is that I can see the file with the sketchup viewer app.
does any one have a solution or a hypothesis to what I can do ?
actually this is the 2nd time I have this issue, I had to just remodel the old file, then decided to reach for help this time :wink:
I use sketchup 2018

It would be helpful if you upload the file so we can see what we get when we try to open it.

Please complete your profile with SketchUp version, operating system, and graphics card. That information helps us help you.

Few moments later (lol), I downloaded sketchup 2020, when I tried to open the file directly with it, it crashed like it did with sketchup 2018, but when I opened a new file and imported the autosave into it it worked, it was a moment of great stress over 2:00 am, so I just slept and was grateful it’s over :relieved:

Thank you @DaveR for your help!

If you, or any one, still want to know I have an intel i5 processor and Nvidia 840M graphics card.