Copy Paste much slower than Move Copy

Hi folks

Using Copy + Paste on a group/component can take a long time (Several minutes to copy).
But Move+copy is instant.

Can anyone tell me if this is normal behaviour?

It’s something I’ve put up with for years but the models I’m currently working from require a lot of copy & paste between groups and it’s slowing me down big time!
Does anyone know the reason for this?

Thanks.

‘copy’ adds it to your ‘clip board’ for placement anywhere [including other models], but ‘move copy’ doesn’t need to as it will be within the current model…

john

1 Like

To add to what John said, SketchUp maybe already has allocated memory for more entities, while the clipboard may need to be expanded, or even write to disk. I don’t know how the OS handles the clipboard internally so this is just speculations.

@AK_SAM

Yes, much to our chagrin, this is expected.

Within a Sketchup instance, the fastest way to copy geometry is to select, move, and then activate copy (Ctrl on Windows) just before committing.

Between two Sketchup instances, however, you cannot move geometry. So natively, you have to copy via memory.

And this often takes many minutes. One minute. Two minutes. Five. Ten. Fifteen. Twenty minutes, indeed. And counting. So, why is this?

Apparently, Sketchup forces lots of internal consistency checks when copying to memory. When creating new containers. When doing many other things. These checks are incredibly slow. From a programming point of view, Sketchup’s behaviour is most likely very badly optimized. There is either something sloppy about the internal database structure, or about how it is being processed, or about both.

We know this because other 3D modellers are much, much faster doing similar tasks. Both copying between instances and doing other editing of non-trivial geometry. Sketchup can do OK in terms of showing complex geometry. It’s editing that grinds it to a halt.

While we’re staring at Sketchup’s blank and irresponsive screen after a sizeable copy, no processor core is even near maxing out. So this process may be memory-bound. Its slowness does not matter when working with three cubes, for it escapes notice. As it did around twenty years ago.

However, when working with contemporary, real-life models, i.e. complex geometry, like you and I do, the recurring waiting times is a real pain.

All this would be bearable if it were not for the fact that other 3D modelers do perfectly fine without all this waiting time. Which proves this is unnecessary:

– Does it work on three cubes? Boy, let’s ship it!

The best explanation, I think, of why this still is so even twenty years after Sketchup’s conception, is that Trimble does not force its product managers to regularly solve pressing, real-life problems in complex Sketchup models.

Like you and must I do. Every day. When Trimble’s product managers have worked every day for a year or two having to solve pressing, real-life problems in complex Sketchup models, they will deal with the problem.

For all of Sketchup’s good aspects – and there are plenty – what you are pointing to is precisely Sketchup’s main weakness:

lack of performance when managing and editing complex geometry.

The solutions are all painful. Either:

  1. Trimble decides to solve it in ernest. They get their hands dirty and start whacking at the core. Or

  2. Users that need complex geometry go elsewhere. E.g. Blender is much faster. Or

  3. We simply invent a time-machine that takes us back to 2001 when this was acceptable.

2 Likes

I vote time machine. Time travel is applicable in more scenarios and would be super awesome.

Regardless of any time travel I’d also like the SketchUp team to work more on optimization and polishing.

2 Likes

Wow what a fantastic response - thank you!

A couple of observations;

  • When copying, I sometimes get a message in my windows task tray saying “Item 24 of 24 not collected. Format not supported by Office Clipboard”.
  • Office Clipboard’s paging file size can be expanded (not sure if that would be good , or make things worse?..maybe smaller is better?)
  • Copying seems to get very slow on large models (more larger items in clipboard? or a larger model to check consistency against?)
  • If you are just copying and pasting a component between Groups/Components within the same model then it’s actually faster to save your Component to your desktop then Drag & Drop it to sketchup. (Dragging it from the components browser is another option - but that itself may take ages to open in a large model).

How to increase the size of the Clipboard:

1. Click the Start button. Type sysdm.cpl into the search box and press the Enter key.
2. Click the Advanced tab in the System Properties window. Click the Settings button under the Performance label header.
3. Click the Advanced tab in the Performance Options window. Under the Virtual Memory header, click the Change... button.
4. Clear the check box next to the Automatically manage paging file_ _size for all drives option. This disables automatic “Virtual Memory” settings in Windows.
5. Enter a value for the size of the new paging file. Enter a value larger than the current paging file size in the “Maximum Size” field (enter the value in megabytes). Click the Set button and then OK .
6. Restart the computer for the new “Virtual Memory” settings to take effect. The Windows Clipboard now stores more data when copying and pasting between applications.

1 Like

Windows page file is an interesting aspect to this issue.

I have experimented with different page file sizes over the last couple of decades and the only variable that has any noticeable difference on performance (incl higher or lower min and much higher max) is to eliminate the page file from external drives (I don’t leave external drives on during the working day).

Are you sure changing the WIN page file also changes the WIN clip board size?

Yes @AK_SAM is correct !