Control over Layout linework

Working with Layout 2019 on a PC. Having difficulty ACCURATELY adding linework to my sheet layouts. Cannot get linework to align to a fixed point and having difficulty creating linework to exact lengths. What am I missing/doing wrong?

Hard to tell without seeing exactly what you are doing. Can you share the LO file. Send it via a PM if it’s got sensitive info.

You have Object Snap off and Grid Snap on. Have you tried swapping those so Object Snap is on and Grid Snap is off?

Does this look more like what you want from the thick lines?
Screenshot%20-%209_30_2019%20%2C%2012_07_34%20PM

You might find it easier to draw all of those thick border lines in one go rather than making them separate lines.

Yes, that is exactly what I want to see. Where do I change those settings?

Change them at the bottom of the Arrange menu.

I tried but couldn’t get them aligned where I wanted them.

That helps immensely. I couldn’t find where those setting options were. Moving on, how about controlling the exact length of linework? Ideally, I want to enter the length as a modelspace length rather than having to calculate what length should be in paperspace.

This is what Scaled Drawing is for. Select Scaled Drawing in the tray on the right. Set the scale to match the scale of the viewport and draw.

I thought when I inserted the drawing and selected
‘scale’ in the pulldown that that set it properly. I have never noticed the Scaled Drawing box in the tray.

How do I get the ‘make a scaled drawing’ setting permanent for the sheet? It seems to reset after every line sequence.

That sets the scale for the viewport from SketchUp. it doesn’t affect drawing with LO drawing tools. You need to do that in Scaled Drawing.

FWIW, it looks like you went to a lot of trouble to get your masking done. There’s an easier way.

With the Line tool in LO, I drew a shape tracing the right side of the viewport following the same edges you did and then along the bottom. I completed the shape drawing up along the left and across the top. Here that shape is selected.

I copied the shape to the clipboard and then selected the shape and the viewport. I right clicked on the selection and chose Create Clipping Mask to end up with this. By default there’s no black line.

I pasted the copied outline to a layer above the layer containing the viewport, used the Split (knife) tool to split it at the lower left and top right corners and then erased the left and top sides of the shape.

1 Like

You don’t. You can open the group that is created while making your first scaled drawing and add more drawing entities to it.

Responses to two of the above comments:

  1. That masking linework sequence is exactly what I need and I’ll try to replicate that in my workflow.

  2. I don’t understand “You can open the group that is created while making your first scaled drawing and add more drawing entities to it.”

I think you’ll find that clipping masks are very useful.

When you make a scaled drawing, the drawing is automatically placed in a group. You can double click on the group to open it for editing.

Here I created a group of the masked viewport and the lines along the right and bottom.

When I double click on the group to edit it, the rest of the document grays out.

You might want to remove your link again. Otherwise you’re putting your address and phone number out there for the world along with that of your client.

Thank you, Dave.

1 Like

Just as a side note and alternative masking method, I do all my masks in Sketchup, it’s easier for me to draw them there and they are done with planes in front of what I want to hide. Faster to render too.