Constraint not approved at this time


#1

WHEN I DRAW A LINE AND INTER A DEMENTION SUCH AS 2 INCHES A RED BOX OPENS AT THE END OF THE DRAWN LINE SAYING “Constraint not at approved at this time” Try as I might I can not get it to draw a line to what ever length I need. Hope someone can help. Oh this is a fresh 2016 down load.


#2

Could you share the SKP file?


#3

Hi Dave, thanks for getting back with me. You have another problem I am over 65 and have been trying to use sketch up for some shop work. Here is the other problem…I have no idea what a SKP file is, and I feel very lucky I can send email at my age; but if there is help I sure would appreciate it. [jim]


#4

I live in Elmira NY and I’m getting ready to hit the hay. Got to get my beauty rest ya know I ll check back in in the morning. Thanks.


#5

The SKP file is the SketchUp file you save when you hit the Save button.

Get your beauty rest and attack it in the morning.


#6

Well David I hope you get this…I have been up since 4am hoping I could figure this out on my own. You my friend have a very tuff fight on your hands. I mentioned that I am very stupid when it comes to tech stuff, even though I try so hard. The latest problem is that I could not get signed back into SketchUp on my lap top so I thought I would give it a try on my phone. During the night a thought came to me about trying to re-down load the Sketch Up program thinking that jyst might cure the problem, but decided to hold off till I heard from you. A side note is that I have the Sketch Up 2015 on my Wife’s computer and it seems to work fine except that you can not use the mouse to orbit or move the drawing in and out. Sucks to be me. Take your time getting around to me I realize its Saturday and you have your own chores to do. Thanks Jim King


#7

Hi Jim,

I wouldn’t try re-installing SketchUp 2016 just yet. That seems like a drastic move that may not be required. Have you tried drawing a line this morning? Are you still getting that message about constraint not approved? Does it happen with any line you draw? Can you describe the exact steps you are using to draw a line when you get that message?

I wonder if there’s someone in the area who knows SketchUp and would be willing to work with you. I think it would be helpful to have someone in the room looking at your computer. Maybe there’s someone in the Art Department at Elmira College or in the local high school who has some experience with SketchUp. They could probably help you make the mouse settings on your wife’s computer so Zoom and Orbit work, too.


#8

Yea Dave, Right after my first cup of coffee this morning, I fired up the HP. and ran through the line tool and rectangle tool. Natta; nothing. There are measurements in the box but the program will not even let me click to enter into the box.I will say you are a genius. I never thought about trying to locate someone in higher education around here to give me some advise. I will put the search on with people I know. I’m sure its just something small I’ll just have to locate the right person. If I were able to use the mouse feature I would just switch with my wife and life would be good. Thanks again for your interest in my problem. Jim


#9

Just to make this clear: you can’t click the value control box (VCB) to enter values, just type…


#10

Just a quick question…Would you happen to be David Richards, a contributor to Fine Woodworking.


#11

Yes, he is.


#12

As Cotty says, yes, I’m that guy.

As he also says, don’t try to click in the Measurements box before entering a value. If the tool you’re using will accept a numerical input value, the field in the box will turn white and the label will indicate the sort of thing it’s looking for. Just let go of the mouse and start typing. Hit Enter to get the value to take.


#13

Cotty when I click on the measurement box nothing at all happens. But if I move the mouse the dementions change in the window according to the size-shape ect.So David must have had himself admitted due to the large headache I have given him.Maybe you gad better run while you have the chance. :slight_smile:


#14

I do have a headache right now but I assure you, it wasn’t caused by you. :slight_smile:


#15

And you will never see a Sage running away from you if you ask for help :wink:


#16

Cotty you are not going to believe this. I think I fixed it. UFBI got a email from Fine Woodworking Magazine. In therevwas a Sketch Up artical on adding more stuff to your current program. Anyway it said to go to Window -Preferences and then something else. Well under General there is a box that said AUTOMATICALLY FIX PROBLEMS WHEN THEY OCCUR. It was unchecked. I clicked on ut and went to the drawing screen. Drew a line as nd entered in 2 inches and wa-la…it worked. Sweet .Have to go to Church in a few minutes but that will be the first thing I check. Got my fingers crossed will advise as soon as I give it a test drive. Whoo whoooo


#17

You should say thank you for this article to Dave, since he’s the author of it :wink:


#18

Thanks a ton for standing by . Ya know I thought there might have been a chance that Dave R was Fine Woodworkings Dave Richards. Isn’t that something. I will be sure to thanks to him also, you both have been terrific.Thanks so much from a very slow and not so smart old man. Jim King, Elmira, NY


#19

David , you my friend are a life saver.Today I received an email from fine woodworking magazine asking me to come back and renew my subscription. In there was your article on adding to SketchUp. Were you mention going to preferences I noticed that under the General Tab there was a block that was “unchecked” saying - AUTOMATICLY FIX PROBLEMS WHEN THEY OCCURE-Well guess what…That did it. I checked this box and said OK. Everything started working just like its supposed to. Isn’t that sweet. Yep d she is working just fine. I can’t thank you enough for your help and your article. In addition I think I just may treat myself and renew My Fine Woodworking. Yep…that’s what I am Going to do.Thanks Dave and a Thanks to Cotty who helped to. Jim King, Elmira, NY


#20

Aw, shucks, Jim.

I’m glad you got some things straightened out and you’re on your way with SketchUp. That’s a good thing.

Cheers,

Dave