Colors inside model

How can I change the color inside the model?

And how to block it so that this does not happen.

Open a component or group for editing. Select the face or faces you want to colour.

Select the paint Bucket tool (shortcut b) and choose the colour you want.

With the paint bucket tool selected click on any of the pre-selected faces, or if you haven’t selected any, click one at a time on the faces you want to (re)colour.

To prevent things showing through, make sure the colour is 100% opaque.

It’s hard to be sure from the image, but it looks to me as if you have done something to the near face of the green stringer - deleted it, hidden it, or made it 100% transparent.

If this isn’t quite what you are asking, upload your model here so someone can have a better look at it.

I hid the side wall. The green color is inside. It’s supposed to be gray. This is what happened with the entire model. How to lock the coloring inside the model?

To clarify, why do you think that surface should be gray? Did you specifically paint it with a gray color? Could it be that your style has the back-side color for faces set to that bright green (something I often do to make reversed faces very visible)?

You don’t understand me. I set the green color to the ground. I accidentally changed color inside the model. I don’t know how. I use Lumion to render. In Lumion I set green for grass. But green is inside the model. In lumion It looks like.

I want to lock the coloring (gray) inside the model.

The grass in the lumion because it is green inside of the model.

The back faces are still green. You could select all faces, right-click Reverse Faces, paint bucket color everything to something that isn’t green, then reverse faces again.

I am guessing that you changed your default back face to green. Then all default faces turned green on the back.

Thanks but how to lock gray color for ever. I’ll set green again by mistake.

Without seeing the model file we are all guessing, but one possibility is that the stairs are a group or component, and you have inadvertently painted it green. The material will show only on those faces inside that are painted with the default material, not on faces painted with something else.

The problem is that this is part of a big model. I don’t know what’s in the group and what’s not. I got it for visualization. If I did it myself, I would optimize for Lumion.

For debugging purposes, this Front-back setting is quick and useful. All colors are gone, but you can see what surfaces are flipped.

It seems to be one group.

Also, what I’m saying is I wonder if the stair is inside out. The renderer doesn’t care what the back face is. it renders front face textures, right?

Edit
In other words;
If: Green = Grass
And: stair renders as grass
Then: the green inside the stair must be the front face

If it is one group then right click on it select Edit Group , then select the face and paint it with desired color. Or as you see in my gif select on the Entity Info and set back to default.

Otherwise if you are posting ONLY screenshot we can not determine if it is one group or not! Post your modell and someone can take a look on it.

It is one group. Probably made in Revit and export to SketchUp.

I don’t have the permission to upload model.

Lumion renders any texture. Front and back.