Code error 104 when trying to save in layout


#1

After I try to make changes and then go to save and I get code error 104. Then it says to revert save. How can I fix this?


#2

Where are you trying to save the file to?


#3

@jeffdoll72, Is this behavior with SketchUp 2016 M1 release? We fixed a similar bug in this release.

Yogesh


#4

Incidentally, were you working with clipmasks in this file before you got the error 104?

-m


#5

I was working in layout. I saved some work into PDF and when I did some more work in Layout and tried to save I got this message.


#6

Did you install the latest maintenance release?


#7

It said everything was uptodate


#8

Having exactly the same problems, file edited in layout will not let me save…
Layout version 16.0.19913


#9

Has anyone figured this out. Im currently having the same issue.


#10

@jkewonus

This bug is seen when you release the clipping mask, hit undo (to redo the clipping mask), and do some operation on the mask (e.g. Edit->duplicate) .

When you see the Error 104 the dialog box presents an option open an earlier version of file. Please use the earlier version and redo the work.

Another alternative is to recover the autosave file. On Mac OS, the Autosave file is in the Temp folder. To access the folder, open a terminal window and type the following

cd $TMPDIR
cd com.SketchUp.LayOut2016.use_your_user_name
open . (this dot is important as it will open the current folder)

The very first LayOut.****** folder is the most recent autosaved content
open this folder and zip the contents (LayOut file is actually a zip file)
change the extension of this file to .LayOut

Hopefully, this recovered file works.


#11

Just got Error 104 in release 17.2.2554. I just installed it las night, but I don’t know if that is the reason for the error. Haven’t seen it before, but I can’t save my project. :confused:

EDIT: I just tried, save as, restarting LO, restarting computer, reinstalling the update, reverting drawing to last saved(per error message direction), releasing all clipping masks, Other files can be saved(so this file has the problem), eliminating patterns (which I had to update after LO reinstall), Observation: sometimes I can save as and it won’t save (error 104) but the auto text will show the new file name, Copy paste rename file… Nothing is working. :rage:

EDIT2: Fixed problem by copying contents of each page to new document. 17 pages worth of reassigning layers - half a day lost. Could have been worse I guess.


#12

I’ve had this problem intermittently through several versions of layout. Just came back again and on enormous layout document I have (24 pages). I copied all the pages over to a new document which is very time consuming as you can’t paste pages in, only the contents of the page and then have to rename each page. Spent about an hour doing it this morning and now my new file is getting error code 104. I do have photos that are using clipping masks in the document. What is the issue here? I can’t keep spending hours chasing this problem around.


#13

Still experiencing this problem. Not dealing with any clipping masks. Its brutal. Anyone else?


#14

Do you have the latest update?
There was a maintenance release last week,
Mac only M3

http://dl.trimble.com/sketchup/SketchUpPro-en.dmg