Clipping problem


#1

Clipping, this is an age-old problem with SketchUp, which just doesn’t seem to be going away anytime soon. It happens for various reasons: geometry too far from UCS, stray geometry that is way far out, etc.

I just wish this could be solved for once and for all. I have this happening on a model I’m busy with at the moment. UCS is fine, no stray geometry that is far out. In fact everything was working fine one minute to the next. I now have a situation where grouped geometry disappears when I enter it, I have various sub-groups, but everything is still well visible until that final double click to enter the particular group. To see what’s happening then I have to zoom all which turns the subject matter the size of half of your little finger nail - totally unworkable.

Drivers are up to date, hardware is rather well specced, plus it was working just fine from one minute to the next. Problem is I need to do some editing to the group in question and will probably not be able to do so now. A real PITA, especially as I’m using SU 2018 Pro and this is a paying job… I have no idea how to fix this so I can do the editing.

C’mon SketchUp, I give you my money every year to stay up to speed with the latest version, why is it that these kind of problems (clipping) cannot be solved?


#2

Is there any chance that you recently changed the setting for Component Edit on the View menu?


#3

No, and this was a group to start off with.

I toggle the view / hide rest of model on / off all the time as needed. Definitely not the problem here.


#4

I have seen this behavior with imported geometry from other cad software, exploding and regrouping whilst still selected after the explode seems to work.


#5

I’ll see if I can somehow explode and re-group. No imported geometry in this file though…


#6

Yep, exploding and re-grouping worked it seems. Thanks Mike.


#7

#8

thanks, not so much a fix as a workaround, shouldn’t be necessary in the first place though


#9

No problem. Yeah, I agree clipping issues are annoying. I think most 3D software has clipping though.