Cleanup weird bug

Yes sir, I already checked these options.
Here’s a screenshot.

I only mentioned browser because the microsoft edge pop-up hijacking informational page was mentioned above.

Hi ThomThom
I followed as far as I could -

but not 100% I have the correct info
Not sure what Microsoft VM and did not spot Java Settings see markup

then the screen shot (hopefully is thw one you are after)

Just an observation. My laptop has a completely different version of windows, which is 8.1. And both my devices have the same issue. It must be something I am doing that I just cannot put my finger on. Thank you for helping anyways.

FYI re IE11: The following was announced last May … I am wondering how this policy will affect the ie engine DLLs that applications use ?

Hi ThomThom

Any further thoughts on problem a couple of us are having with Clean up and teh mysterious black/Dark Grey dialogue box

Embedded web views should continue to work. That retirement is for the IE browser app.

I’m afraid not. It’s hard when it’s not easily reprodusable on every machine.

Thats a shame. Would you mind if I throw it open to the rest of the community for any ideas to solve the problem?

This is not a private message… the whole community is already seeing this!

Hello ThomThom,

We’re having the same problem with cleanup.
Blank menu window.

what have I done already.
Uninstalled sketchup and deleted all the files in the appdata/roaming/sketchup
then Installed Sketchup (as administrator).
Then added the plugins. But still no menu arggghhhh

Is it possible it has something to do with the register?

Same bug, Windows 10 V 22H2

Is there a workaround (ruby ?) to change the config UI of cleanup, as cleanup still seems to work ?

Are you referring to Cleanup3 by thomthom ?

Hey @thomthom

unfortunately the bug still exists so I tried to fix it on my own. I checked the Ruby Console while pressing on »Clean…« in your menu. This was the output:

Error: #<NameError: uninitialized constant TT::Win32::OutputDebugString>
C:/Users/MARIOSUNSHINE/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2/debug.rb:36:in `debug'
C:/Users/MARIOSUNSHINE/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2/window.rb:32:in `block in <class:Window>'
SketchUp:1:in `call'
Error: #<NameError: uninitialized constant TT::Win32::OutputDebugString>
C:/Users/MARIOSUNSHINE/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2/debug.rb:36:in `debug'
C:/Users/MARIOSUNSHINE/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2/inputbox.rb:133:in `event_inputbox_ready'
SketchUp:1:in `call'

After that I checked the debug.rb file and commented out line 36:

#Because of the annoying Window Bug in Cleanup³ "#{str}\n\0" )

Now it works again! :yum:

The window is not empty anymore and now I’m able to use it as planned.

But… I’m not really sure if this uncommented Line of Code will affect other ThomThom Plugins?

@thomthom: What do you say? Anny comments?

Greets Mario

@MarioSunshine : Followed your advice. It worked! Congrats.
This helps me a lot.
So far my installed other thomthom plugins (solid inspector, material replacer, selection toys) are still working.

1 Like

Happy 2 hear that! :ok_hand:
Have fun!

PS: I think the debug.rb File does not really affect other ThomThom Plugins. I think it’s more for debugging Plugins… :wink:

I looked at this a few days ago and found that in the latest revision of TT_Lib2 the file named

C:\Users\UserName\AppData\Roaming\SketchUp\SketchUp 20XX\SketchUp\Plugins\TT_Lib2\win32.rb

is missing a small detail. The following should be inserted after line 19.

    include Win32Win32APIImpl # constants

This bug only affects versions of Sketchup that run Ruby 2.5 or earlier.

Edit :tagging @tt_su


Cool, that did the trick…
Thanks a lot! :pray:

Thank you Mario. I had same problem in quadface tools!

Thank you, thank you, thank you. This fixes the grey screen on Cleanup.

Version 2.13.1 has been published. This includes the fix for older SketchUp versions.

Available via Extension Warehouse and SketchUcation.

Sorry for the inconvenience.

Updated version has fixed the grey screen problem

1 Like