Can't uninstall SketchUp 8


#1

I installed SketchUp 8 a couple of years ago. Now I’m insterested on uninstalling it, but everytime I try it says:

This function you’r trying to run is not available. It’ sais it’s missing GoogleSketchup8.msi. Altough the program runs fine. Any idea to solve it?

Thanks for your time.


#2

The GoogleSketchup8.msi is the v8 installer file, which you ran initially to install it.
If you have not kept it then you get the error because the Uninstall option looks to [re]use it in its processing.

Here is a link with an answer - but it involves looking in the registry… so use with care…


#3

Presumably reinstalling/repairing SU 8 using the SU 8 M5 installer would facilitate uninstalling. (Yes ?)

Unfortunately SU 8 is no longer available for download.
Downloading older versions — SketchUp Help / Download Older Version Page

Rather than fiddling with the Registry, perhaps one of us has a clean copy to share.
That is, if that’s all right with the SketchUp folks.
@AlexB … Your thoughts?


#4

The files are still online, I can post the direct links if it’s allowed?


#5

Are you saying the SU 8 M5 installer is available directly from Trimble or from some ‘other’ source on the Web?


#6

Directly on Trimble’s site. The Mac version file is named PM-3-0-16845-EN.dmg


#7

Windows version is named PW-3-0-16846-EN.exe


#8

Why would Trimble have it up on the Web for download if it wasn’t allowed?

SU 8 M5 Installer on my system (PC).



#9

I see the M numbers in the prerelease forum. I’m looking at the end user page version. Does those also have the M1, M2, sequence?

Not sure if the EXE is the actual installer, or a zip file of some sort. The installer inside the zip may have a more sensible name. The Mac installer is actually named SketchUp Pro 8.0 Installer.pkg.

I’m downloading the Windows one, to see what it’s like. It’s taking some time to download!


#10

So, I can’t uninstall it since I can’t get the installation .msi? That only leaves messing with the regystri as TIG said?


#11

The registry fix may be the quickest way. I just installed SketchUp 8 under Windows 8.1. It showed a message saying how old it is, and suggesting I update to 2015! That aside, the one I installed was completely branded Trimble, though it still installed into a Google folder. I didn’t see mention of GoogleSketchup8.msi anywhere.

Was there a Google branded version 8 too? That one might be harder to find online, so Geo’s suggestion of getting permission to give you the installer might be worth pursuing.


#12

Lots of reliable forum members probably have a clean copy of the SU 8 M5 installer on their system.
Patience, while we sort out the EULA ramifications of sharing the installer.

Given SU 8 is long unsupported one would think redistributing the installer is OK.
I just think it’s wise to ask the SketchUp folks first.

Maybe @Barry can help us out.


#13

In the fog of uninstallers it may have slipped by that it can happy sit side by side with other versions.


#14

SU 8 was initially released 9/1/2010 … prior to Trimble

From the Release Notes

SketchUp 8 - Maintenance Release 5
Released 12/19/2012

Version Numbers:
Win 8.0.16846
Mac 8.0.16845


#15

Wait a min… if you run the installer on a machine where IT’s version is already installed, should the installer should display a messagebox with a choice whether to Uninstall or Repair ?


FYI, the msi archive (Microsoft Installer package) is inside the exe archive. The exe archive can be opened with 7zip pr other archive tools (just do not double-click the exe, instead open 7zip first, then use the “open inside” feature.)
Manually extract or copy the msi file someplace outside the exe archive.


#16

Thanks DanRathbun. Didn’t know about the .msi being inside the .exe. But since I don’t have the installation file can’t get it .
I have tried installing the new version, but it doesn’t say anyting about reparirng or uninstalling older versions. And the repair option in the control panel doesn’t work either. It also asks for the .msi


#17

No it will not. I was referring to the old version’s installer.


#18

Thanks to DanRathbun I got to uninstall it :smiley:

Thanks you all for your time and your help.

If someone can close this post go ahead, the problem is solved.