Can't select anything in Sketch VR (Oculus) Tracker does not work

Hi there,

The selection tracking does not work on Sketchup VR with Oculus Rift(regular) on my windows 10 machine. Tracking for the Oculus Rift works with every other app, it’s only sketchup that is having this problem. I’ve tried various ways including rebooting, resetting my view multiple times, going in and out of the app, opening the app before opening the oculus app, etc. I can’t do much without being able to head track and select menus in sketchup.

Basically the little line that shows my selection tracker barely moves left and right or up and down as I sway my head around. Maybe something to do with a badly scaled rotation matrix for tracking? (it’s as if the tracker is tracking on a view space that is 100x100 pixels while the menu is 1000x1000 pixels).

Resolution on my monitor is 5k x 2k if that is causing to the confusion for sketchup. Any help would be appreciatred. Thank you.

What is the Windows system Display Scaling set at ?

Right click desktop > Display Settings
Scroll down to “Scale and Layout

Generally the main SketchUp modeling application supports only up to 150% display scaling.

You may try playing with the general setting or advanced settings with the Viewer.

Hi Dan,

Thanks for the reply. I have tried rescaling to 100%(I was on 200%) and it still does the same thing. I’ve tried finding advanced settings for the viewer but I can’t find them. Where can I change its settings?

Thanks.

Changes should be done with applications closed. Perhaps a reboot ?

I was referring to advanced system settings via a link just below the general scale setting as described earlier.

One of the advanced settings is whether to allow Windows to automatically scale apps.
Another has to do with setting differing scale factors for separate display monitors.


Per application settings might be in Nvidia Control Panel. (Guessing)

The only other thing I can think of is are you using the primary or secondary display ?

I have a rather weird set up doing a Nvida dual graphics card on SLI on a 5k monitor that requires dual HDMI cable input(so I have 2 HDMI cables from my monitor to the two cards, with a third HDMI to the oculus headset). Not sure if that is the cause of the problems. So I did try rebooting after setting it to 100% as well as scaling back resolution to 1600x1200 and rebooting as well. Not sure why it’s doing this but the selection bar just stays put as I rotate my head still.

As for advanced settings on windows control panel, it doesn’t seem to give me any options past what I could do earlier with resolution and UI scaling.

Thank you for the suggestions so far.

1 Like

Well that’s all I can think of. I suggest opening a support ticket.

Also there are some support links in the VR Viewer User Guide …

https://help.sketchup.com/en/sketchup-viewer/sketchup-viewer-vr

This topic was automatically closed after 183 days. New replies are no longer allowed.