Can't login to SketchUp Web

Are there any other computers on the same network that you can try? That would help to know if it’s an issue with your network or our server. Also, would you be able to do a test where you use a phone as a hotspot?

I’m having the same trouble today; just used this Sketchup version 3 days ago, so I assume I have the current version. When I open it says the subscription server response is invalid. I’m not sure if it’s referring to my company’s server or Sketchup’s server.


Currently, Korea is in the same situation.

Exact same thing for me (USA) – can’t even get into my account via the browser. (Firefox)

i am in Hong Kong and get the same, I login ok then open file and get ( The subscription server response is invalid) i need to work how can i resolve this and get on.

Looks like it might be a known issue:

I need to use it now and this happened!!!

Are there any compensations about this, i´m paying a subscrption

Looks like it’s back! Thanks crew, hope everyone else is on too.

same thing still happening to me in Safari v15.2 / MacOS Monterey 12.1

For all of the new reports, try my post here:

I’ve tried with another computer on the same server and it works. It doesn’t when I use a phone as hotspot.

I was able to get in on a PC and Macbook but unable on the Chromebook

Try the clear cache suggestions for Chromebook:

That points to there being some security setting on your computer and not the network router.

I am not sure now what your options are. For any paid version of SketchUp I would ask a colleague to screen share with you, to try and figure out the problem. But for the Free version I don’t know what to do.

I will check with the web version team to get suggestions about what to do next.

Thank you for your help.

Can you assist with registering/whitelisting our Domain in order to use SketchUp For Schools?

Ok, thanks for all the help anyway!
Don’t worry too much about finding a solution if you think it is due to security settings; I have asked my school technician, and he will probably find out what the problem is. It was to know if the bug came from the SketchUp/Trimble side that I asked here.
Thanks again for your help.

My school technician managed to sort out the problem; it was due to restrictions.


Someone else who had the issue had an ad blocker in place. Maybe your case was the same thing.

1 Like

Hi, I have a similar problem logging in. I have subscribed to sketchup Pro until November 2022. Before that, everything worked. Today I cannot log in. When I click “sign in” it redirects me to a blank trimble page. I cleared my history and chrome cookies and still nothing.


For what it’s worth and if anyone checks in on this. I’ve had issues in the past with the login page showing up as it did for @AEG. (ie like the screenshot shared).

As most recommendations here above would state, I had disabled plugins, cleared caches etc. but that still did not resolve the issue. The issue it turns out was something was something quite specific.

Looking at the network console in my browser (Firefox) I noticed it was failing to load a resource from the domain (specifically “”). On other browsers I tested, this was not the case. That was the clue I needed. Failure to load that file caused the entire login page to quietly fail. After a little further checking I figured out that Firefox could not resolve the DNS of that domain. The reason it could not resolve the domain was: I had enabled “DNS-over-HTTPS” in the browser and set the provider to be with “” as custom provider. As it turns out, Brave’s DNS service treats like an ad network.

So here are a couple of recommendations:

  • To Trimble: A cookie script should not make your login prompts fail.
  • If you use ad blockers, you will need to turn these off for Trimble sites depending on the lists you have loaded. See the first bullet… And yes there are lists that have cookielaw on them aside from Brave’s DNS
  • If you still have problems, check your browser console and dig deep (or learn how to).