Can't instal STL extension


#1

I have SketchUp version 8.0.16845 and I downloaded sketchup-stl-2.1.4.rbz – but when I go into my preferences and click on the “instal extensions” button, I get a message saying “SketchUp was unable to instal the Extension you have chosen for some unknown reason” then helpfully suggests I check the extension’s documentation for additional help. But the documentation says it should be compatible with SketchUp 8.


#2

Hm…
What OS do you have? Windows or Mac? Are you running as admin user or normal user?


#3

Good call! I have Mac OS 10.9.4 but I was using a regular (normal user) side. Usually I get a prompt to enter an admin name and password when its needed, so I didn’t think that could be the trouble – but when I switched to admin it worked! Thank you!


#4

Hm… I’m glad you got it working. But it sounds odd still. Extensions should be installed to the user’s directory which he should have access to. …oh wait… this was SU8… we might have been trying to install to the global folder. This was changed in SU2013 I think.


#5

I have the same problem with a mac 10.10.1 (Yosemite), I can not install the extension Stl … I run the download from Warehouse and I got "sketchup-stl-2.1.4.rbz "but this file only shows me how to edit text document then Sketchut 8 does not install. how should I do? What’s wrong? can you help? thank you.


#6

this is the message that gives me sketchup when I try to install the extension


#7

You seemed to have left out the error message.


#8

I’m not sure what you mean by this.
How are you trying to install? Make sure you have the latest version of SU8 and use Preferences > Extensions > Install Extension.


#9

Certo è proprio così che faccio, conosco la procedura, e la mia versione di sketchup e 8.0 ,ma non va; quello che intendevo dire è che il file scaricato : “SketchUp-stl-2.1.4.rbz” non mi arriva in formato “Plugin” ma in formato “Textedit”.


#10

Download the file “SketchUp-stl-2.1.4.rbz” to somewhere safe - perhaps your Downloads folder ?
Then Open SketchUp [it must be >=v8M2]
Use SketchUp’s [Windows > ] Preferences > Extensions > Install Extension… button
Find the ‘RBZ’ file. and choose to install it…
Done.

Scaricare il file "SketchUp-stl-2.1.4.rbz" al sicuro da qualche parte - forse la cartella 'Scarica' ?
Poi aperto SketchUp [deve essere> = v8M2]
Usa SketchUp [> Windows] Preferenze> Estensioni> Installa Estensione ... pulsante. 
Trovare il file 'RBZ', e scegliere di installarlo ...
Fatto,

#11

This and the first thing I did, but it does not go! Maybe it is not clear the problem, when unloading the file “SketchUp-stl-2.1.4.rbz” by Extension Warehouse I get a file format “text” and not a format “Plugin” … … what can be ???


#12

Is there a file downloaded which is named “SketchUp-stl-2.1.4.rbz” ?
Or are you saying that if arrives as “SketchUp-stl-2.1.4.txt” ?
You mention ‘TextEdit’ earlier…

What is your OS - I guess MAC.
Set you Safari options to NOT mess with downloaded file-types, or to try and extract the contents of any compressed format file.
If the downloaded file has the .RBZ suffix, and it is not messed-up by the download processing, then the Install tool will read it and install it properly, irrespective of the file-type reported in the Finder [which might revert to TextEdit if it’s ‘unknown’]…

You speak of format ‘Plugin’ ??
There is no such thing ?
Do you mean ‘RBZ’ or some such ?

Note that an RBZ archive is actually a renamed ZIP file containing the Ruby RB/RBS files and other ‘helper’ files used by that toolset, these are almost always inside a subfolder…
If you change the file-type suffix to .ZIP can you see its contents ?
If you change the suffix to .RBZ can you not use the Install, button ?
All the Archive-installer does is that it extracts the contents of the archive into the Plugins folder, keeping some files inside their subfolders as appropriate, and then loads any new Ruby files added into that Plugins folder…

If you are still having problems then a screen-shot or two would help us understand you better…