Can't get rid of black lines that form on selection box


#1

Normally the selection box is blue and disappears when you click away from it. I had sent my 2D design to Layout. I was working in Layout then at some point and I don’t know how, the blue select box had a solid black line around it which covered my design and if a tried to to delete it, it would delete my design. If I clicked away somewhere else the black outline box would remain. Eventually I found that if I right clicked on the black outlined box and pressed explode the box would disappear. But then the select tool was not working after that I could not do such things as change the scale in the trays on the right side (the tray was there but would not let me click on anything because I guess nothing was selected. Luckily I was almost done at this point so I could just print it off and hand in the assignment, but to tweak anything in the trays I had to start over it seemed.

Any idea what happened or how I can solve this if it happens again? Thanks


#2

Some screenshots could help finding what you have going on. Or the layout file itself.


#3

The few times I’ve run into strange and sporadic changes in software behavior, I’ve always been able to fix it by restarting the program, and/or re-booting the computer.

The one common thread which all of these events seem to have shared (as I’ve come to believe things) is they all happened during long working sessions—where I had the programs running for many hours straight. and hadn’t restarted the computer for multiple days.

Also, there would be long periods of inactivity between me jumping in-between simultaneously running programs.

I don’t have any great technical reasoning behind this theory, but It sure feels like the most likely explanation is based on how software wakes up, and transitions from being an inactive background program which has been sitting in memory, to an active program.

Somehow, for lack of better words, it’s as if the program doesn’t fully wake up to resume 100% of it’s expected duties. Instead you get a solid 95% or so, with the anomalies being weird behavior in responsiveness, selection issues, hidden cursors, and other discrepancies that are off just enough to make you think twice about what you thought you knew concerning how things were supposed to work… which I hope makes a little sense.

Anyhow, these days I have a little better warning system in place, and I tend to better anticipate when it’s time to restart my programs, or re-boot the entire system.


#4

Is it possible that all you needed to do was turn off Stroke in Shape Style while the viewport was selected? Without something to look at it, it’s just a guess.


#5

Plot Plan 2.layout (220.9 KB)

Thanks for the ideas folks. With what JimD described, I was keeping the session open for a long time so it could have had to do with a software malfunction. I am also quite new to Sketchup so perhaps it was something simple like DaveR suggested. I have attached the layout file here. But I am not sure if it will show anything. Unfortunately, I have not been able to open Layout on my computer although Sketch Up opens up fine. It worked fine last week so quite strange. I just realized this now when trying to work on a new assignment. Sketch Up won’t even let me send to Layout anymore. I am on the 30 day trial of Sketch Up Pro. Looks like I have have to uninstall and reinstall the program.


#6

Once the 30 days are up you lose Layout, and uninstall and install won’t fix that.
If you want layout you need to buy Pro.


#7

Nope. You’ve used up the trial period. It looks like you’ll need to purchase a license to continue using SU Pro and LayOut.

I don’t see any black border other than the one around the edges of the page. I do see that you have the plan on a shared layer so when it is selected, the bounding box is maroon instead of blue.


#8

Hi Dave. Actually, it says l still have 23 days left of the trial since l
just started last week and the trial lasts 30 days.

The reason the box looks like that is because when the black outline
appeared over what was the blue selection box (seemed like a glitch) and l
could not get rid of it anyway after spending hours trying l just right
clicked on it and pressed explode, then the maroon box with dots appeared
like in your screenshot which at least didn’t affect my printing but it did
become difficult to work with and redo any scales etc.

Not having layout work doesn’t explain the malfunction l experienced. Any
other ideas why sketch up layout glitched out with the black outline around
the selection or why layout stopped working when l have 23 days left of the
trial? Thanks


#9

The maroon color indicates that the selection is on a shared layer which you can see when looking at the Layers window.

Did you install SketchUp correctly using Run as administrator when clicking on the downloaded EXE file? If you didn’t, that might account for LayOut not opening.

If you can get it sorted out and reconstruct your file with the black border, upload that file. At this point it’s too late to work with the file you already uploaded.


#10

Did you right click on the install file and choose “Run as administrator” or did you double click on the install file to get it to run? The right click method is the only correct way to install SU. With the double click method all sort of crazy things happen.


#11

Thanks for the tips. I will try installing with the right click.


#12

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.