Can't edit "In model" materials


#1

I was working on a model, everything was fine and out of the blue the context menu for In model materials stopped working. When I right click on the material within Materials window, SU freezes for a few seconds, Windows says “Not responding”, the whole scene goes black, renders again and unfreezes, but the context menu won’t show. I tried to restart SU, but no luck. Have I added some material that causes the problem? How can I find out the reason or fix the project file?


#2

Your profile states you are using v 14.0 ?

You should update to SketchUp v 14.1 or even better 15.3.


Close Outliner window, and turn off textures while editing materials.


#3

I tried closing Outliner window and editing materials while in wireframe display mode, but it won’t help.

I figured out that https://3dwarehouse.sketchup.com/model.html?id=uf0508e29-9563-406b-afc2-a51cbd40ab52 is the culprit. Since I added this to my project, I can’t edit materials. Even though I deleted the model from my project, deleted the layer it was added to, I can’t edit materials, I can’t purge unused ones. Is there anything wrong with this model?


#4

That model has over 121,000 polygons.


#5

You still need to purge the used component definition.


#6

Like Dan says, the model is huge.
It’s certainly nice to look at as a standalone model.
But in the context of a larger model it’s sure to slow things down.

Be mindful of what you bring into your model.
The 3DWH displays the file size and polygon count.


How to Purge