Can't delete lines within shape to allow me to push/pull the shape in one piece

Hi there

I’m trying delete some lines to leave a shape that I can push/pull in one go, but when I try to delete the lines within the shape so that the required shape remains on it’s own, it deletes the face within the shape instead. Please can anyone tell me what I’m doing wrong, thank you.

Also, on a separate note, for some reason, the guidelines I’m drawing seem to disappear when I zoom in. Does anyone know what might be causing this? My main query is the push/pull issue above.

I’ve attached a video and the model.

Thanks in advance for any help that can be provided, it is very much appreciated.

Paul


Model.skp (198.9 KB)

The problem is that you’ve drawn your model slightly off axis so the geometry of the hole isn’t dividing the surface correctly. Here I’ve set precision higher than you had it so the differences show up. All of the Y values should be identical here.

It would help if you turn off Length Snapping in Model Info>Units and keep your model closer to the origin. It’s a long way away considering the size.

Aah, I see, thank you Dave. That makes sense. I wonder how I managed to draw it off axis by such a small margin, I use the arrow keys to project and fix my lines to draw them. That would explain the guidelines disappearing too I guess. I’ll make the adjustments as you suggest.

Many thanks.

Paul

Probably has to do with having Length Snapping turned on. Here I’ve redrawn that part after moving the model close to the origin. As you can see, all of the Y values are the same here. This was done with Length Snapping off and making sure I enter actual dimension values.

I was using your version of it for reference when I redrew it. I found a lot of dimensions that I suspect you don’t really intend. A few shown here.

As for resolving it without redrawing it, I think there are enough problems with it, you’d be time ahead starting over.

Thanks Dave. I’ve learnt a lot, especially regarding length snapping, that will save me from problems in the future. Cheers. Paul

1 Like

Happy to help, Paul.

A couple of suggestions in addition to turning off Length Snapping:

Set precision to as high as it will go for the units you are working in. The precision will be higher than you’d need in the real world but this will allow you to see when things are out. Depending on your tolerances, this can make the difference between a part that is in spec and one that is out. If you need to create dimensioned drawings from the model you can reduce Precision to as few places as needed.

Set up the units, precision and Length Snapping off in a new blank model and save that as your default template for future use. Then you don’t need to remember to make those settings each time you start up.

And I mentioned before keeping the model close to the origin. My preference is start at the origin and work right in the direction of the solid red axis and back in the direction of the solid green axis. Keep the front of the model aligned with the red axis. That will make the standard views make sense. The standard Front view is set with the red axis running left to right across the screen.

Good luck and keep plugging away.