Can't cut through a wall


#1

As you can see from the picture above I have two structures. I can cut through the wall of the one on the right to create a door opening, but when I try to do the same thing with the one on the left push pull creates an extruded boss instead of an extruded cut. Does someone know why this occurs?


#2

How are you determining the distance to extrude? After you start the push pull you should move the cursor to an inference on the other face (any of its edges will work) and click there to set the depth. If that absolutely won’t work, most likely the faces of the wall aren’t parallel.


#3

Inferencing pp to the other side of the wall worked. What’s weird though is that when I cut the door opening for the one on the right the offset is limited, so pp was still able to cut regardless of the distance I extrude to. If I did the same thing with the one on the right, pp would create an extruded boss not cut.


#4

FWIW, I have found the reliability of PP in this respect a bit suspect. In theory, you should be able to use PP until it recognises that you have reached a back surface. If you release at that point, you make a perfect cut. But all too often, it doesn’t work and I find I either have to inference to a suitable point/line/surface or go beyond as you show and then push it back (and often have to delete the surface retained). If the two surfaces are not perfectly parallel, it won’t work at all, as Steve says, but that’s another ballgame altogether!


#5

Here’s a kind of example. the only difference between the two “buildings” is that the one on the left was created by push/pulling the wall up and the other was created by using follow Me from a vertical section. The latter has its faces reversed for some reason. The first one behaves perfectly and won’t allow you to push beyond the back face of the wall. But on the other one, it will.

I haven’t tried this with every conceivable permutation of wall creation, but suffice to say that I have seen its erratic behaviour so often that I now just accept that sometimes it plays nicely and sometimes it won’t.


#6

Usually the “offset limited to” message means that there is something that intersects the extrusion path and causes confusion about what the extrusion should do. But in any case, inference to the opposite side is the most reliable technique.