Can't assign new shortcut, nor reassign O to Orbit tool

SU 2016 Pro on Mac.

I was trying to assign a shortcut to the Edit/ContextMenu Flyout/Dynamic Components/Redraw menu.

Whatever key I entered, I was told either ‘Key cannot be used as a shortcut’ or else ‘Shortcut Assigned’.

Experimentally, I used O for Orbit, which I don’t normallyl use as I have a wheel mouse. That WAS accepted, but I changed my mind, and want it back.

Now when I try to assign O to Camera/Orbit I get told again ‘Key cannot be used as a shortcut’.

Any fixes for either problem? I’ve tried quitting and restarting SU.

Sounds really odd. It shouldn’t really do that.

If you don’t have any other shortcuts modified, you can utilize “Reset All” shortcuts?

or, make sure you are just hitting one key on keyboard, “O” and clicking on the “+” button right afterwards.

I know by experience the shortcut assigning is slightly different in MAC environment, and sometimes you cannot assign something that is already being utilized by the OS. Is it possible that you might have O being used for any OS based operations?

(1) The Redraw command makes no sense unless a DC is selected, and the selection is single-object. So SketchUp may not be allowing a shortcut for such a conditional command. (Speculation.)

(2) Did you try first unsetting the O shortcut for the Redraw ? … before attempting to assign it to Orbit again ?

Thanks for those thoughts.

I have a few personalised shortcuts, though not enough to cause a real problem if I have to reassign them.

I was only pressing the O key, and I don’t HAVE a + sign in the dialogue:

I get this:

And when I press Enter I get:

I never was able to confirm the assignment of O to Edit/ContextMenu Flyout/Dynamic Components/Redraw - even after accepting the option to replace the already assigned O for Orbit.

I did have my DC selected, and was able to ‘see’ the Redraw context menu when I was trying to set the shortcut.

Maybe the missing + sign is the clue, and my pressing the Enter key after entering a letter or Ctrl is just telling me that I can’t assign the Enter key to a shortcut, which would make a sort of sense?

But I have in the past on this machine been able to assign a custom shortcut - Shift+D for the Dimension Angle plugin. That’s still working, and shows up in the Shortcuts list when I search for Dimension.

And I have assigned Ctrl+V to Edit/Paste in Place - which shows in the Preferences/Shortcuts, and works, but doesn’t show in the SU Edit menu, even though the standard shortcut Edit/Paste (option+V) does show.

In fact, now I look in the SU menus, I can see that the shortcuts shown are all scrambled. Not sure if I can take a screen shot, but (for example) Tools/Tape Measure shows Option+D as the shortcut, but I actually use the standard T.

ALL the shortcuts shown on the Tools menu are wrong.

I’m running on OS X El Capitan v10.11.4 - has this recent update affected anything on SU recently?

This is a bit of a mess. How to recover? Reset All shorctuts, and reenter the custom ones?

Find and delete the shortcuts.plist file, as I’ve seen in other posts about shortcut problems on Mac?

PS. As far as I know, O without a modifier key isn’t a standard Mac shortcut for anything - but I’m new to Macs. It used to work fine for Orbit, and WAS previously assigned to that, though I didn’t use it much.

PPS. Further experiment. If I assign a shortcut key, then click somewhere else, it seems to get saved, even though I haven’t a + button. So, for example, I assigned Y (for Yes) to the DC Redraw command, and it has stuck, and works. But it too doesn’t show as an assigned shortcut in the Context menu list.

And that technique has enabled me to get the O for Orbit back too.

Small but very confusing bug? Where’s the + symbol gone in Preferences/Shortcuts? And why are the menus showing mostly wrong shortcuts?

Only the File menu seems to show all the right shortcuts.
The Edit menu is mostly right, but partly wrong further down, and is missing my Ctrl+V custom shortcut near the top.
The Draw menu is mostly wrong
The Tools menu shortcuts shown are all wrong and also missing my custom shortcut Shift+D for Angular Dimension
The Camera menu shortcuts seem mostly wrong, but I don’t use enough of them to know for sure.

??? Where to go next to fix? Will have to sleep on it - way past bedtime here in UK (1:50am).

Funny, because I am UK based as well. Well past bed time, but its weekend!

Sorry for the confusion that I might have created by saying stuff that is regarding windows, not MAC. It has been awhile since I have worked on a MAC since I sold off mine due to tiny discrepancies and inconsistency like this.

If I remember correctly, you shouldn’t hit Enter after you assign a shortcut. I think you just click elsewhere to accept the new assigned shortcut. Because you might be assigning “return/enter” for orbit.

you are not supposed to see + sign.

When I had MAC I did notice all shortcuts being scrambled, I dont think that is an issue though.

I have no recollection of a + button in Shortcuts on any mac version of SU…

The ⌘ + letter shortcuts are hardcoded, go back to before you could set Preferences and they still all work…

you can set a non letter ‘Custom Shortcuts’ that works for the same function…

you can use ⇧⌥⌃ + letter but need to hold down control then the key to use it…

Any of these ‘Custom Shortcuts’ never appear in the menu…

most mac dialogs you need to hit Return and/or click out of, to leave the edit status…


Thanks for all of that. So I have a working solution, the menus are all OK (just unexpected), so I just learn to live with Mac vs Windows custom and practice differences.

Just got into bed, but replying from phone. Don’t have to worry while going to sleep.

Many thanks for the clarification of what’s happening and that it is normal behaviour in SU on Mac.

Just ran into the same problem, and this thread helped resolve it for me, but I thought I’d add some clarification.

Like the OP, I am using a Mac with OS X El Capitan (10.11.6). I was using SU a while ago (several years) on my older Mac and I definitely assigned shortcuts, but I don’t remember running into this issue. Now I have a new(er) Mac and just downloaded SU Make '17 and started playing around with it and went to start assigning my old shortcuts and ran into the same “Key cannot be used as a shortcut.” message WHEN I HIT RETURN (which is the same as enter).

This is generally true, but in this case hitting Return seems to be causing the problem and you have to “click out of” to make it register. I also tested “Tabbing” out and got the same error as when I hit Return.

I think that hit the nail on the head.