Cannot select componets to load into online project


This is really annoying me. I live in the country where the internet is not great. I was working on a project for a wood storage pallet. I have used and enjoyed using Sketchup in the past. When I went to use Sketchup 2016 it said that I had to upgrade to the latest version. I did not want to use the online version due to poor internet. I downloaded the 2018 version, and designed my project. Today I wanted to open the project to start actually building the project and it said my 2018 trial version had expired. I decided to use the online version, but could not upload the file from my computer. That selection was greyed out, and not usable. Researched on the net. It said to upload it as a component to the warehouse. Ok did that. Opened a new project online and figured out how to open the 3d warehouse. Found my project, but I cannot bring into my current project. I cannot select or view the file from the warehouse, but I can see the thumb nail and description.

Did more research and updated my browser…no change
opened a new project and defined the unit…no change

I have wasted many many hours messing with this. Can someone tell me why I cannot bring that project into my current project?

Thank you

The 3D Warehouse supports the 3 most recent versions of SketchUp so that is 2017, 2018, and 2019. There are numerous threads on this topic where the reasons have been explained. You can read them so I’m not going to waste time rewriting all of that.

If you want to continue using SketchUp 2016 and you want to download components from the Warehouse, you can access them via your internet browser, download the Collada file and import that. Alternatively, you can model them yourself.

Instead of installing SketchUp 2018 Pro, you could have installed SketchUp 2017 Make which would not have expired and you’d still be in good shape.

If you are using SketchUp Free, you could upload your model to Trimble Connect using your account and then open it from there by clicking on the file folder and then Open.


Give us the link to your project in the Warehouse so we can see what you are working with.

You should be able to just drag a skp file over your browser, hover, and you’ll see the text “Drop your file here”. Release, and it should show up.

1 Like

Thank you Dave,

I exported the file and reloaded in Sketchup 2016. That solved my problem

My question was, why could I not select that same file from the warehouse into the online version of Sketchup?

Still, I do appreciate the quick reply.

Thanks again.

Hard to say. I haven’t had any problem importing from the 3D Warehouse to the online version so I don’t know what you are doing differently. How big is your file?


That is exactly what I thought I should be able to do. It would not let me drag it into my current project, or select the file which usually gives me a new screen with the option to download it.

It shows me the thumb nail picture, but the size and download options are greyed out. I tried dragging, right, and left click, no luck

I did what Dave posted in his responce and I am now back on SU2016 on own computer.

Thank you for your reply


It was not just my file, it was all files. I even searched for car and all of those files have the same issue.

My file is small .15mb and according to the download number it has been downloaded 123 times. Totally unsure why, it is just a layout to put sides on a pallet for wood storage. Unless it is recording how many times I tried to down load it. File name is Wood Pallet 32x40.

thank again.

I can’t tell you why it did open for you. It did for me. Perhaps as you say, your internet connection is bad.

That is strange. I found it, loaded it 3 times into the free online version and it worked fine and was quick.

At a recent trade show, I found the component browser search results are so lacking, it was faster and easier for me to open a separate tab with 3dwarehouse, download, then drag-n-drop into the free or EDU version of SketchUp.


Still having the same issue of using the warehouse. Although now, when I open the file menu I do have the option of Add a Model. Before it was greyed out. I just uploaded the same file from my desktop to the online version, works fine.

I am guessing that it might have something to do with my internet.

At least I can go back to using SU2016.

thanks for your time