Cannot select any file while importing or able to close the window

Hi,

I just installed Sketchup Pro and I am following the " SketchUp for Landscape and Site Design" course, currently, I am trying to import an image, but when I click on Import, the files window appears but I cannot click anything except the format list, even cancel does not work.
what could be the issue or where should I check next, I was only able to exit this by forcing the app to quit.

Sketchup 2022 Pro, MacOS 12.1

I suspect you may have clicked “No” when SketchUp asked if it could access your files and folder - so now it can’t…

You want to find this area in the Security and Privacy settings of your mac

and make sure SketchUp is ticked for both Files and Folders and Full Disk Access if there is the option to do so.

not sure what the problem was, I went to the security settings and it was not giving any action when I tried to click on Privacy so I restarted the machine, and rechecked Privacy, it is allowed for Sketchup
so after the restart, everything worked fine. and I am able to import the file