Cannot open Warehouse


#1

When I uninstalled old versions 2010 and 2014, I get following when opening 2015 newest version, which I have used a long time:

Error: #<Errno::EACCES: Permission denied - C:/Users/Timo/AppData/Local/Temp/SCF/SketchUcation_Usage.log>
c:/users/timo/appdata/roaming/sketchup/sketchup 2015/sketchup/plugins/sketchucation/!scfapitools.rbs:178:in initialize' c:/users/timo/appdata/roaming/sketchup/sketchup 2015/sketchup/plugins/sketchucation/!scfapitools.rbs:178:inopen’
c:/users/timo/appdata/roaming/sketchup/sketchup 2015/sketchup/plugins/sketchucation/!scfapitools.rbs:178:in log_write' c:/users/timo/appdata/roaming/sketchup/sketchup 2015/sketchup/plugins/sketchucation/scf-rbztools.rbs:180:inrescue in module:RBZtool
c:/users/timo/appdata/roaming/sketchup/sketchup 2015/sketchup/plugins/sketchucation/scf-rbztools.rbs:174:in <module:RBZtool>' c:/users/timo/appdata/roaming/sketchup/sketchup 2015/sketchup/plugins/sketchucation/scf-rbztools.rbs:157:in
C:/Users/Timo/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/SketchUcation/SCF_loader.rb:28:in eval' C:/Users/Timo/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/SketchUcation/SCF_loader.rb:28:inload’
C:/Users/Timo/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/SketchUcation/SCF_loader.rb:28:in block in <top (required)>' C:/Users/Timo/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/SketchUcation/SCF_loader.rb:17:ineach’
C:/Users/Timo/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/SketchUcation/SCF_loader.rb:17:in <top (required)>' C:/Program Files/SketchUp/SketchUp 2015/Tools/extensions.rb:197:inrequire’
C:/Program Files/SketchUp/SketchUp 2015/Tools/extensions.rb:197:in load' C:/Users/Timo/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/!SketchUcation_loader.rb:191:inregister_extension’
C:/Users/Timo/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/!SketchUcation_loader.rb:191:in <module:SCF>' C:/Users/Timo/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/!SketchUcation_loader.rb:16:in<top (required)>’.


I am not able to open warehouse or load anything to warehouse or go any place via help in program.
I have repaired program two times. WIN SketchUp 2015 Make M3 RC2 ENx64

Timoko


#2

reinstall the Sketctucation Plugin and see if that remedies the issue…

equally, it my be showing an error do to Internet connection problem, that also effects the Warehouse, help, etc…

john


#3

Hey,
I deleted all application data of sketchup old and 2015.
I reinstalled sketchup make 2015.
Ofcourse I lost all installed plugings.
I can open Extension warehouse and use it normally.
When trying open 3D warehouse to get models or share models, all I get is blank window with two lines in center of window.
I also had difficulties to plug in here, only after changing password it was possible.

Timo


#4

On PC, CTRL+L and navigate to –
https://www.whatismybrowser.com/is-javascript-enabled is javascript enabled?


#5

I recovered application data, so I have all installed plugings in sketchup and I got back all errors.
Only thing what is not working is 3D warehouse. I can open 3D warehouse via Google and load models but not in sketchup.
Maybe reason is that I deleted Firefox and Internet Exploder. When I have tried to install them, they are not working. Blank page opens and I am not able to go any settings or open any page.
Timo


#6

My Google is ofcourse CROME


#7

Sketchup dialogs are always IE despite your choice of default browser.
You need to make Internet Explorer work.


#8

To use SketchUp’s features like Trimble’s EWH and 3dWH, and many Plugins [like the SketchUcation toolset] - which all need an Internet connection - on a PC you must have a fully working version of Internet Explorer [preferably v11] - on MAC the equivalent is Safari.
If you use some other browser for your day-to-day Internet use it is of no importance in this regard - SketchUp always uses Internet Explorer [on a PC].
If you have somehow uninstalled it [or otherwise crippled it], then no wonder things are broken…
Reinstall Internet Explorer - get the latest version [v11].
Perhaps you also need to repair your Windows installation, and then apply any IE updates ?
Also remember that Internet Explorer’s “Internet Options” need to be set up to be not too strict or limiting; and, as has been said earlier, IE’s Javascript must be fully enabled - this is because many ‘web-dialogs’ rely on it for communications between SketchUp, Ruby and often sites in the outside world too…


PS: I’d also get the latest version of the SketchUcation-Toolset and reinstall it from the RBZ. The errors you are getting with that might be from an improper installation or wider IE issues - we can’t tell…

#9

Hey,
for some reason some of my users folder were “read only” when I corrected that Exploder and SketchUp work fine.
Thanks


#10

Wow, add another checklist item to “why is 3dwarehouse blank”.


#11

which user folders were ‘read only’?


#12

I did not look, but when I was not able save my work as same name, I looked properties and square was dimmed. I then changed properties of whole folder.