Cannot open 2015 in "Make" mode

HI There,

Has there been a fix for this yet? I have a several labs (150 computers) to image next week and this current copy of “Make” is giving this same error! I have to use 2015 because the old version is not compatible with Google Earth. So basically I need a fix now for this. We are not at all concerned with running Pro, so if there is a way to not offer it and just install Make that would be great.

I have the same problem. System running Windows 7 Ultimate 32 bit. Noticed as several others that my system clock was changed by about a month into the future? - the only program that I have loaded when this happened was SU 2015. I did not want the Pro version and loaded what I thought was Make and ended up in this trial and problem.

Hi Bugra,

I’m using SketchUp 8 on my mac (OS X 10.9.5) but would like to create things with SketchUp 2015 Make…
I’ve got the same Problems like almost all in this treat (After installation of SketchUp 2015 Make (German version) → licence expired)
Could you help me too?

Hello, mr bugra, please add me to the list. My experience is very similar to @giuseb. Clearly there is some file hidden that keeps the history of the license checkouts, even in tommy’s Make splash screen he was identified as a expired Pro user. And I have never changed my system clock. I also think the security settings affect the result, as with @giuseb I got different validation pop ups. Other factors may be that I think I did the mountain lion to yosemite upgrade during the trial period, and I also experimented with some of the Pro features (intersect faces) on practice designs during the trial.

Question I do have is whether there is any way to restore from Time Capsule to a time before the license expired? I suppose you would need to know what to restore.

@bugra Another data point. I do run Windows 7 VM under latest Parallels version on Yosemite. I downloaded and installed Make and it works fine, can check again after the trial expires if this problem returns

All, I have tried to reach out to everyone on this thread via private message. Not everyone got back to me but rest assured, there will be a fix for this in the near future.

Add my name to the list of people with this problem.

Running OSX 10.9.5, never used SU before now. Definitely downloaded the Make version, not the Pro version.

Any help would be appreciated.

Edit: tried on Windows 7 (through Parallels), and actually got the 30-day trial working. That helps with the immediate problem, but I’d still like to know why the Mac version doesn’t work.

dggrow here and I have not heard from you that I am aware of. I posted 9d ago

Hi Willy, I also have to image a large CAD lab this week. Have you found any work-around to this issue yet?

Hello all, we just released a new version of SketchUp 2015 which we believe fixes these issues you have been experiencing in Make. Thanks a lot for your patience!

Hello there,

Use 32 bit installer even if you have a 64 bit machine!!

note : this message will be deleted shortly by team members!!! I dont know why?

they should try to fix the problem instead of deleting user posts

Hi there @1984_emre,
Sorry, this isn’t good advice. What problem would it solve to install 32-bit SketchUp on a 64-bit machine? I don’t see the relation to any of the Make issues being discussed. Maybe I’m missing something.

sorry I’m not with you,

I have had the same prob. about starting(not able to start) sketch up make 2015 as others have on this topic,

than uninstalled make 2015 64 bit software and tried with 32 bit installer,

anyway, it is a wortless situaiton to be a member for this forum after seeing your declamation,

maybe you re missing this topics headin huh!

maybe you should write for wiki for your new releases!!!

@1984_emre: I’m sorry to have upset you, it wasn’t my intention. I just didn’t understand why 32-bit installation would solve this problem on a 64-bit OS (and I still don’t). There must be another explanation for why it worked for you. Is the latest 64-bit installer still not working for you? If so, I would love to know that and try to help you get it working.

I am well aware of the issues being discussed here (since I am the engineer in charge of fixing them). There were a few issues with the licensing system that we fixed with the latest release. Another issue was that the website was accidentally serving the Pro installer instead of Make on some 32-bit machines. This should also have been resolved.

Howdy All. Is there a fix for this yet? I downloaded the latest version of SKM 2015 and removed the directory from ~/Library/Application Support/SketchUp 2105 but I’m still getting the licencing issue. Someone posted that there was a new version but that post seemed to be about a month ago. Thanks!

Jeeeeze, I didn’t see tha there was an “I agree” button to accept the make license. I’m in!

I am still trying to get 2015 Make to open on my Windows 7 Laptop. Still get the bugsplat screen after uninstalling and reinstalling 3 times…is there an outlook for the fix to be available or would I be better served trying to find and load the 2014 version?


So your problem probably has nothing to do with the license problems (probably fixed in the latest maintenance release) discussed in this thread.

If you get a bugsplat, the first thing to try would be to look for and install an update to your graphics card driver software.

Powerful laptop computers often have an integrated Intel graphics chip in addition to the real graphics card. In this case you should also check in the graphics card control panel 3D settings that SketchUp is set to use the graphics card, not the chip.


Thanks, Anssi…

It is a Lenovo Laptop with an Intel Chip Set and the graphics SW is current. I can’t see an independent graphics card in the control panel to try and adjust 3D settings as you recommend.

One interesting thing is when I look in Program Files under Sketchup I have a Sketchup 2015 folder that contains the license file, a “Layout” folder and a “SketchUp” folder. The "Layout folder has numerous files that you would expect, but the “Sketchup” folder is empty!

I’d appreciate any ideas you or Bugra might have!


That’s strange. Is it possible that you looked in ProgramData (as opposed to Program Files)? That’s the only way this would make sense.

Do you see the bugsplat dialog come up? If so, please submit a report with “Poetzing” in the comments and I’ll find it.