Cannot Login/Create Account on iPad version

#1

Using SketchUp Viewer on ipad Air 2 - that I bought new in 2015. iOS version 12.2. Last used SketchUp Viewer in Nov 2018 - last time the weather was good enough to work in my shop. Discovered today that I needed to log-in to use the application. I did have automatic updates on, so likely the version that functioned the way I expected was updated to what I have now. I’d not had to do that ever before, so I tried to create an account. Application would go to a blank login screen (login.sketchup.com) and stay there. Please assist.

0 Likes

#2

It used to be that the AR feature was just enabled with a subscription to that feature. Now the feature is also turned on if you have one of the subscription SketchUp products. So now you need to sign in, before two months ago you didn’t.

I have seen blank screens too, but only I think when there was a server issue. Normally the login.sketchup.com redirects to identity.trimble.com. You could try going to:

http://app.sketchup.com/app

in Safari. That will show the same login screen that you’re not reaching in the viewer app. If it fails that might give be relevant.

I tried on my iPhone and iPad, and signing in is working ok for me at the moment.

0 Likes