Cannot insert scaled CAD layout into sketchup layout?

So I have inserted two scaled CAD drawings into my sketch up layout. Now I am trying to insert more scaled CAD layouts and for some reason it takes me all the way through where I select which layout in CAD I want to insert, click okay, and it does nothing and does not insert any scaled drawing from my CAD file. It works for some of my CAD files but not all. I for the life of me cannot figure out why or what is happening?

Are you working in SketchUp or in LayOut? Your post is kind of confusing on that.

What happens if you insert the CAD file in question into a separate session?

I am using SketchUp Layout 2020. I have tried using a separate session in Layout and in CAD. Neither have worked. The plans that I have been able to insert into Layout had no issue and are scaled like we need. However for certain CAD files/layouts, it will still take me through the prompt where you choose the layout page in CAD, choose paper or model space etc. hit enter but then nothing is inserted.

I’ve moved your thread to the LayOut category, then.

So clearly inserting CAD files into LayOut projects works. What is different about the CAD files that don’t work? Evidently there is some difference that makes them not readable. Have you tried importing those CAD files into SketchUp to see what you get there?

I am not sure what is different about these CAD files. The floor plans I am trying to scale into layout are able to import into sketch up just fine.

Maybe you could share one of the CAD files that gives you problems so we can see what we get.

Hi Jordang, verify that a scale is applied to the viewport in CAD first. If your viewport does not have a scale assigned to it LayOut will not import it.

If the data is only contained in the model space, then the Model Space Only option in LayOut, it will come in at a scale that you then can set to what you want.


1 Like

It’s strange I have my viewports to scale and it was still not inserting. I did however change it to model space only after cleaning it up a bit and it imported fine. Changed the scale in Layout and its just what I need. Thank you all so much I really do appreciate it.