Cannot find the issue with this STL in Lychee slicer

Hi guys - I cannot find why Lychee slicer keeps choking (crashing) on this STL file? It was created from a solid model (exported as STL). Any ideas what causes the issue?
Wing model.skp (131.4 KB)
Wing model.stl (73.7 KB)

Size/scale, yes sketchup has issues with tiny faces but it also has issues with huge ones too. One curve in your model is ~ 1541540.94 mm

Sorry I should have said, I have tried it both in actual size (26mm wide) and x 1,000 scale

Having said that, your stl is easily scaled to fit within my slicer.

In most slicers/3d printer software, you can select scale and input a specific size. I can set your huge stl to 26mm on the x axis and it all scales appropriately.

You should scale up by 1000 and then change the model units to meters. Stl does not convey units, so if your slicer expects mm, it will take the stl as being in mm.

1 Like

@slbaumgartner - got it, and that works! issue resolved! sorry! it was the first time this happened

I should delete my posts but I’ll leave them incase others may understand them and find them useful.

1 Like

Adding another graphic to illustrate for anyone else who might come along.


Screenshot - 6_11_2024 , 11_32_09 AM
FWIW, when modeling for 3D printing I start with model units set to meters. No need to scale up, down, or sideways. Just do the modeling as if millimeters are meters, export the .stl, and open in the slicer.

And if necessary use the Scale option to set a specific size.

1 Like

You are certainly more experienced with that but so far I’ve never found a case where I had to scale the model in the slicer. It’s always the desired size when it opens. Is there a certain situation where scaling in the slicer would be required?

I was simply referring to the attached stl. when opened in Cura it is huge but you can select it, choose scale, and type in 26mm on the x axis and it will resize to that.

1 Like