Can one embed a 3D viewer in a keynote or powerpoint presentation

I’m giving a presentation in a couple of weeks, using several SU models. I’d like (if it’s possible) to embed a 3D viewer in several different slides.

I won’t have Internet access at the presentation site, so I can’t use the Web viewer in a browser.

Is this possible? Or shall I have to content myself with a screen capture of looking around in a SU model?

Alternatively, I can switch to SU itself on my laptop, connected to the digital projector, but it would be nicer to click on either a static image or a link on the slide to open a 3D viewer (ideally, full screen) which when closed would revert to the slide show.

It used to be that Microsoft Office would allow the embedding of SketchUP files for 3D viewing but last I heard Microsoft had removed that capability.

Thanks, Dave. That could have worked, but I don’t have a recent enough copy of Office to do that - mine’s from 2010!

I mostly use LibreOffice on Mac for “Word”- like documents, and Keynote for presentations (which I now do very rarely).

To whom do you want to make a 3D presentation?

Something that is possible on iPad, and I think should be possible on Mac, you can export your model as USDZ, to Files, then drag that into a Keynote presentation.

Not fully sure of what control you have, but you can at least size the model and orbit around it.

I’m away from my Mac at the moment, otherwise I would have tried the steps in the Mac version of Keynote.

Thanks, @colin I’ll try that later today.

It’s a local discussion group, the Baconian Club of St Albans, established 1921.

I’m a former President, and currently Secretary.

We meet in a venue with no Internet access.

That should have been what I asked about.

Not currently possible on Mac (SU 2023.1.341) - no USDZ in Export options.

I see there are paid extensions. If you have a recent iPad you could drag the model to the iPad with AirDrop, open it and export to USDZ, then drag the USDZ back to the Mac.

I’ll try that - I have a fairly recent iPad.

Confusingly I uploaded my Mac model to Trimble Connect, but my iPad and desktop iMac seem to refer to different accounts - there are no models showing on the iPad in Trimble Connect, and nothing happens when I try to sign out and in again - |I seem to stay logged in and don’t get another Login screen to try a different email.

Though it appears to be the right email, and the right product licence.

I’ve had a similar issue when I tried TC recently, because it has different servers :
US / Europe / Asia / Australia

I think I remember seeing the default “sketchup” folder in the US server, regardless of where you’re actually located.
On the other hand, if you - being in the UK - uploaded to the european server, it might explain why your ipad doesn’t see it. it could be looking in the US in the default sketchup server.

In your trimble connect account, check the various servers to see where things are located, and maybe experiment ? :slight_smile:
(I never use TC, but maybe someone around here has experience with this specific issue?)

Thank you, @ateliernab. That may well be what’s happening, especially since I bought the iPad in California. My models are saved on the European server.

May not have time to check that today, but in the meantime I’ll get the model to the iPad via Dropbox or even memory stick!

1 Like

Other solution, the 3d warehouse.

publish your project there, and access it through your browser (no the in-app warehouse)

it allows you to download in USDZ, even if you upload it as a private model.
(private models don’t have AR mode, but do have the 4 format choice)

Capture d’écran 2024-03-02 à 16.47.32

That sounds like a better short term solution - I’ll give it a go today or tomorrow.

I don’t get a choice of format after uploading the model to the 3D Warehouse (from inside SU 2023.1.342 if that makes any difference) - clicking on the Download button goes straight to this dialogue:


and whether I click OK or No, it starts a download immediately of the .skp file, either into my open SU file, or to my Downloads folder.

[LATER]
I get the download format options only if I go to the Warehouse in a browser. Then I get the choices you did.

Bit then another roadblock - the USDZ format is greyed out and there’s this message on top:
image

???
This is the model in question: one of the models I’m trying to view inside Keynote.

Baconian badges box.skp (1.2 MB)

And this is the link to the Warehouse model.

Any known factors in a model that stop it generating a USDZ file?

I found another of my 3D warehouse components DOES offer a USDZ download, but when I download it, I can neither drag and drop it into Keynote, nor Import it - it seems to be a file that Keynote can’t deal with.

That one was a Live Component that I’d created when trying out Live Component editing.

GRRR!

since the USDZ format is the one used by the AR view, I wonder if you need to FIRST upload as public (so the AR USDZ is created) then you can switch to private to hide it from the world.

I tested earlier using a public file that I switched to private, so its USDZ version already existed.

anyway, since keynote won’t read it, it’s a moot point I suppose… back to the drawing board.

Hmmm. I wonder if this is a function of my OS? I can’t upgrade my hardware beyond Monterey, so maybe USDZ wasn’t supported in that OS?.

[quote=“john_mcclenahan, post:16, topic:262030”]
Any known factors in a model that stop it generating a USDZ file?

I didn’t make mine a private model at all, so the reason can’t be that only public models can make USDZ files.

well the AR thing is not immediate, I recall reading it could take a few hours. so if your file was brand new, maybe it was too early?

I';; try it again tomorrow, then. 12:30am here now in UK